summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlair Bonnett2024-03-12 09:55:03 +0100
committerBlair Bonnett2024-03-12 09:55:03 +0100
commit4b75e31fa59e93c8ebf624cd8a4f8419e13336b5 (patch)
tree09c0b4b352a3761261093e775bee29a7af313dda
parent3875d2ca980e429ae02f8e9041920639eca25872 (diff)
downloadaur-4b75e31fa59e93c8ebf624cd8a4f8419e13336b5.tar.gz
Update to 1.0.10; run tests in check()
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9cc893f3371..8dd730d0568b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,12 @@
pkgbase = python-quaternionic
pkgdesc = Interpret NumPy arrays as quaternionic arrays with Numba acceleration
- pkgver = 1.0.8
+ pkgver = 1.0.10
pkgrel = 1
url = https://quaternionic.readthedocs.io
arch = any
license = MIT
+ checkdepends = python-pytest
+ checkdepends = python-pytest-cov
makedepends = python-build
makedepends = python-hatchling
makedepends = python-installer
@@ -12,7 +14,7 @@ pkgbase = python-quaternionic
depends = python-numba
depends = python-numpy
depends = python-scipy
- source = https://files.pythonhosted.org/packages/source/q/quaternionic/quaternionic-1.0.8.tar.gz
- sha256sums = 8301d3b15842ebd24f0415f1da0bf32774b2b9357e4db7e8a9ee01e170dc7700
+ source = https://files.pythonhosted.org/packages/source/q/quaternionic/quaternionic-1.0.10.tar.gz
+ sha256sums = a726631f0a7afbbbae4473a6676bbcdf999a27d51e2e88d39e60ef728a88ca3c
pkgname = python-quaternionic
diff --git a/PKGBUILD b/PKGBUILD
index 305a6cc4a9aa..2ab328d82369 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Blair Bonnett <blair dot bonnett at gmail dot com>
pkgname=python-quaternionic
-pkgver=1.0.8
+pkgver=1.0.10
pkgrel=1
pkgdesc="Interpret NumPy arrays as quaternionic arrays with Numba acceleration"
url="https://quaternionic.readthedocs.io"
@@ -9,13 +9,14 @@ arch=('any')
license=('MIT')
depends=('python-numba' 'python-numpy' 'python-scipy')
makedepends=('python-build' 'python-hatchling' 'python-installer' 'python-wheel')
+checkdepends=('python-pytest' 'python-pytest-cov')
_pypi="quaternionic"
source=(
"https://files.pythonhosted.org/packages/source/${_pypi::1}/$_pypi/$_pypi-$pkgver.tar.gz"
)
sha256sums=(
- '8301d3b15842ebd24f0415f1da0bf32774b2b9357e4db7e8a9ee01e170dc7700'
+ 'a726631f0a7afbbbae4473a6676bbcdf999a27d51e2e88d39e60ef728a88ca3c'
)
build() {
@@ -23,8 +24,15 @@ build() {
python -m build --no-isolation --wheel
}
+check() {
+ cd "$_pypi-$pkgver/tests"
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m installer "../dist/$_pypi-$pkgver-"*.whl
+ test-env/bin/python -m pytest
+}
+
package() {
cd "$_pypi-$pkgver"
- python -m installer --destdir="$pkgdir" dist/*.whl
+ python -m installer --destdir="$pkgdir" "dist/$_pypi-$pkgver-"*.whl
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}