summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorButui Hu2021-11-11 13:28:05 +0800
committerButui Hu2021-11-11 13:28:05 +0800
commitfa80b144352f4d5d1c5e1f616c21b5a8c76e55d4 (patch)
tree648113b12c187cb6e0d34fcbaec1276509f27d03
downloadaur-fa80b144352f4d5d1c5e1f616c21b5a8c76e55d4.tar.gz
first commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eaf8b21d2730
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-qudida
+ pkgdesc = QUick and DIrty Domain Adaptation
+ pkgver = 0.0.4
+ pkgrel = 1
+ url = https://github.com/arsenyinfo/qudida
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-opencv
+ depends = python-scikit-learn
+ depends = python-typing_extensions
+ source = python-qudida-0.0.4.tar.gz::https://github.com/arsenyinfo/qudida/archive/refs/tags/0.0.4.tar.gz
+ sha256sums = 3f6a7838c3578deec662e63a8cae4ef8d836f6b0d970714be347f868cdcbf232
+
+pkgname = python-qudida
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5f25c34e6a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Hu Butui <hot123tea123@gmail.com>
+
+_pkgname=qudida
+pkgname=python-qudida
+pkgver=0.0.4
+pkgrel=1
+pkgdesc='QUick and DIrty Domain Adaptation'
+arch=('any')
+license=('MIT')
+url='https://github.com/arsenyinfo/qudida'
+depends=(
+ python-opencv
+ python-scikit-learn
+ python-typing_extensions
+)
+makedepends=(
+ python-setuptools
+)
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/arsenyinfo/qudida/archive/refs/tags/${pkgver}.tar.gz)
+sha256sums=('3f6a7838c3578deec662e63a8cae4ef8d836f6b0d970714be347f868cdcbf232')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: