summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-04-19 01:27:21 +0300
committerDimitris Kiziridis2020-04-19 01:27:21 +0300
commit932fbcfa8ba869a406611a961b67bff84fa38fd8 (patch)
tree46a664d2dacd378085ee1f80de6827ed74f0d848
downloadaur-932fbcfa8ba869a406611a961b67bff84fa38fd8.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD19
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c770f5ceb98
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-questplus
+ pkgdesc = This is a simple implementation of the QUEST+ algorithm in Python
+ pkgver = 2019.4
+ pkgrel = 1
+ url = https://github.com/hoechenberger/questplus
+ arch = any
+ license = GPL-3.0
+ makedepends = python-setuptools
+ depends = python
+ depends = python-json-tricks
+ depends = python-scipy
+ depends = python-xarray
+ source = https://github.com/hoechenberger/questplus/archive/2019.4.tar.gz
+ md5sums = 510213f181df17d1194159b66307f9de
+
+pkgname = python-questplus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eaf6250eeb44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=python-questplus
+pkgver=2019.4
+pkgrel=1
+pkgdesc='This is a simple implementation of the QUEST+ algorithm in Python'
+arch=('any')
+url="https://github.com/hoechenberger/questplus"
+license=('GPL-3.0')
+depends=('python' 'python-json-tricks' 'python-scipy' 'python-xarray')
+makedepends=('python-setuptools')
+source=("https://github.com/hoechenberger/questplus/archive/${pkgver}.tar.gz")
+md5sums=('510213f181df17d1194159b66307f9de')
+
+package() {
+ cd "${srcdir}/questplus-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+} \ No newline at end of file