summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-14 18:53:25 +0300
committerDimitris Kiziridis2020-05-14 18:53:25 +0300
commita0d2910c645cb4e7421059854923b1b2c0dd8805 (patch)
treec00026f1b71661151f512db1004f791e46dbf817
parent932fbcfa8ba869a406611a961b67bff84fa38fd8 (diff)
downloadaur-a0d2910c645cb4e7421059854923b1b2c0dd8805.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c770f5ceb98..e9ec561959bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,14 +4,14 @@ pkgbase = python-questplus
pkgrel = 1
url = https://github.com/hoechenberger/questplus
arch = any
- license = GPL-3.0
+ license = GPL3
makedepends = python-setuptools
depends = python
depends = python-json-tricks
depends = python-scipy
depends = python-xarray
- source = https://github.com/hoechenberger/questplus/archive/2019.4.tar.gz
- md5sums = 510213f181df17d1194159b66307f9de
+ source = python-questplus-2019.4.tar.gz::https://github.com/hoechenberger/questplus/archive/2019.4.tar.gz
+ sha256sums = 9137a51abbbf50d0040e413391c894227e19f4d366dbcbcc30ba51c6cadd75fa
pkgname = python-questplus
diff --git a/PKGBUILD b/PKGBUILD
index eaf6250eeb44..32547ab631f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,16 @@ pkgrel=1
pkgdesc='This is a simple implementation of the QUEST+ algorithm in Python'
arch=('any')
url="https://github.com/hoechenberger/questplus"
-license=('GPL-3.0')
-depends=('python' 'python-json-tricks' 'python-scipy' 'python-xarray')
+license=('GPL3')
+depends=('python'
+ 'python-json-tricks'
+ 'python-scipy'
+ 'python-xarray')
makedepends=('python-setuptools')
-source=("https://github.com/hoechenberger/questplus/archive/${pkgver}.tar.gz")
-md5sums=('510213f181df17d1194159b66307f9de')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/hoechenberger/questplus/archive/${pkgver}.tar.gz")
+sha256sums=('9137a51abbbf50d0040e413391c894227e19f4d366dbcbcc30ba51c6cadd75fa')
package() {
cd "${srcdir}/questplus-${pkgver}"
python setup.py install --root="$pkgdir/" --optimize=1
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
} \ No newline at end of file