summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-05-21 13:13:21 -0500
committerCarlos Aznarán Laos2023-05-21 13:13:21 -0500
commita9962d6e3d1b50aa0b555e5e28122308991a0911 (patch)
treee0f98e9f8ea3a192438cab92e00ee1c7a31e99ba
parent54b616ed2861769beefd576e8457d8455648be4c (diff)
downloadaur-a9962d6e3d1b50aa0b555e5e28122308991a0911.tar.gz
Bump version to 1.14
-rw-r--r--.SRCINFO15
-rw-r--r--CHANGES.rst170
-rw-r--r--PKGBUILD65
3 files changed, 38 insertions, 212 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0862ff3f5716..180de9b574b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = python-quicktions
- pkgdesc = Fast fractions implementation in Cython
- pkgver = 1.13
- pkgrel = 2
+ pkgdesc = Fast fractions data type for rational numbers
+ pkgver = 1.14
+ pkgrel = 1
url = https://github.com/scoder/quicktions
- changelog = CHANGES.rst
arch = x86_64
license = Python
- makedepends = python-setuptools
- makedepends = cython
makedepends = python-build
makedepends = python-installer
+ makedepends = python-setuptools
makedepends = python-wheel
+ makedepends = cython
depends = glibc
- source = python-quicktions-1.13.tar.gz::https://github.com/scoder/quicktions/archive/1.13.tar.gz
- sha256sums = 4dfbe8dee81099deb28059aeeed72e7b47e22c4204be4ad52aef501b49bd21e7
+ source = quicktions-1.14.tar.gz::https://github.com/scoder/quicktions/archive/1.14.tar.gz
+ sha512sums = e3fc652919b1eb95783d7860ba2481238b72e86ecc71ab5431fde4ec9e51d281d66f2f5f97d5b42089dde384b04bf92eea2edca859ce680cf16483224b7c0513
pkgname = python-quicktions
diff --git a/CHANGES.rst b/CHANGES.rst
deleted file mode 100644
index 71f7b9890b6d..000000000000
--- a/CHANGES.rst
+++ /dev/null
@@ -1,170 +0,0 @@
-ChangeLog
-=========
-
-1.13 (2022-01-11)
------------------
-
-* Parsing very long numbers from a fraction string was very slow, even slower
- than ``fractions.Fraction``. The parser is now faster in all cases (and
- still much faster for shorter numbers).
-
-* ``Fraction`` did not implement ``__int__``.
- https://bugs.python.org/issue44547
-
-
-1.12 (2022-01-07)
------------------
-
-* Faster and more space friendly pickling and unpickling.
- https://bugs.python.org/issue44154
-
-* Algorithmically faster arithmetic for large denominators, although slower for
- small fraction components.
- https://bugs.python.org/issue43420
- Original patch for CPython by Sergey B. Kirpichev and Raymond Hettinger.
-
-* Make sure ``bool(Fraction)`` always returns a ``bool``.
- https://bugs.python.org/issue39274
-
-* Built using Cython 3.0.0a10.
-
-
-1.11 (2019-12-19)
------------------
-
-* Fix ``OverflowError`` when parsing string values with long decimal parts.
-
-
-1.10 (2019-08-23)
------------------
-
-* ``hash(fraction)`` is substantially faster in Py3.8+, following an optimisation
- in CPython 3.9 (https://bugs.python.org/issue37863).
-
-* New method ``fraction.as_integer_ratio()``.
-
-
-1.9 (2018-12-26)
-----------------
-
-* Substantially faster normalisation (and therefore instantiation) in Py3.5+.
-
-* ``//`` (floordiv) now follows the expected rounding behaviour when used with
- floats (by converting to float first), and is much faster for integer operations.
-
-* Fix return type of divmod(), where the first item should be an integer.
-
-* Further speed up mod and divmod operations.
-
-
-1.8 (2018-12-26)
-----------------
-
-* Faster mod and divmod calculation.
-
-
-1.7 (2018-10-16)
-----------------
-
-* Faster normalisation and fraction string parsing.
-
-* Add support for Python 3.7.
-
-* Built using Cython 0.29.
-
-
-1.6 (2018-03-23)
-----------------
-
-* Speed up Fraction creation from a string value by 3-5x.
-
-* Built using Cython 0.28.1.
-
-
-1.5 (2017-10-22)
-----------------
-
-* Result of power operator (``**``) was not normalised for negative values.
-
-* Built using Cython 0.27.2.
-
-
-1.4 (2017-09-16)
-----------------
-
-* Rebuilt using Cython 0.26.1 to improve support of Python 3.7.
-
-
-1.3 (2016-07-24)
-----------------
-
-* repair the faster instantiation from Decimal values in Python 3.6
-
-* avoid potential glitch for certain large numbers in normalisation under Python 2.x
-
-
-1.2 (2016-04-08)
-----------------
-
-* change hash function in Python 2.x to match that of ``fractions.Fraction``
-
-
-1.1 (2016-03-29)
-----------------
-
-* faster instantiation from float values
-
-* faster instantiation from Decimal values in Python 3.6
-
-
-1.0 (2015-09-10)
-----------------
-
-* ``Fraction.imag`` property could return non-zero
-
-* parsing strings with long fraction parts could use an incorrect scale
-
-
-0.7 (2014-10-09)
-----------------
-
-* faster instantiation from float and string values
-
-* fix test in Python 2.x
-
-
-0.6 (2014-10-09)
-----------------
-
-* faster normalisation (and thus instantiation)
-
-
-0.5 (2014-10-06)
-----------------
-
-* faster math operations
-
-
-0.4 (2014-10-06)
-----------------
-
-* enable legacy division support in Python 2.x
-
-
-0.3 (2014-10-05)
-----------------
-
-* minor behavioural fixes in corner cases under Python 2.x
- (now passes all test in Py2.7 as well)
-
-
-0.2 (2014-10-03)
-----------------
-
-* cache hash value of Fractions
-
-
-0.1 (2014-09-24)
-----------------
-
-* initial public release
diff --git a/PKGBUILD b/PKGBUILD
index 2c1d025f500f..83662051b58d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,41 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
+_base=quicktions
+pkgname=python-${_base}
+pkgver=1.14
+pkgrel=1
+pkgdesc="Fast fractions data type for rational numbers"
+arch=(x86_64)
+url="https://github.com/scoder/${_base}"
+license=(Python)
+depends=(glibc)
+makedepends=(python-build python-installer python-setuptools python-wheel cython)
+# checkdepends=(python-pytest)
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
+sha512sums=('e3fc652919b1eb95783d7860ba2481238b72e86ecc71ab5431fde4ec9e51d281d66f2f5f97d5b42089dde384b04bf92eea2edca859ce680cf16483224b7c0513')
-pkgname=python-quicktions
-pkgver=1.13
-pkgrel=2
-pkgdesc="Fast fractions implementation in Cython"
-arch=('x86_64')
-url="https://github.com/scoder/quicktions"
-license=('Python')
-depends=('glibc')
-makedepends=(
- 'python-setuptools'
- 'cython'
- 'python-build'
- 'python-installer'
- 'python-wheel')
-# checkdepends=('python-pytest')
-changelog=CHANGES.rst
-source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('4dfbe8dee81099deb28059aeeed72e7b47e22c4204be4ad52aef501b49bd21e7')
+prepare() {
+ sed -i 's/format_spec, \//format_spec/' ${_base}-${pkgver}/src/quicktions.pyx
+}
build() {
- cd "quicktions-$pkgver"
- # needs to build src/quicktions.c first
- python setup.py build_ext --inplace --with-cython
- python -m build --wheel --no-isolation
+ cd ${_base}-${pkgver}
+ # needs to build src/quicktions.c first
+ python setup.py build_ext --inplace --with-cython
+ python -m build --wheel --skip-dependency-check --no-isolation
}
-## tests segfault
+# # tests segfault
# check() {
-# cd "quicktions-$pkgver"
-# local _py="$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')"
-# PYTHONPATH="$PWD/build/lib.linux-$CARCH-$_py" pytest -x
+# cd ${_base}-${pkgver}
+# python -m venv --system-site-packages test-env
+# test-env/bin/python -m installer dist/*.whl
+# test-env/bin/python -m pytest
# }
package() {
- export PYTHONHASHSEED=0
- cd "quicktions-$pkgver"
- python -m installer --destdir="$pkgdir/" dist/*.whl
-
- local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
- install -d "$pkgdir/usr/share/licenses/$pkgname/"
- ln -s "$_site/quicktions-$pkgver.dist-info/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/"
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm 644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
}