summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-09-12 00:05:21 -0500
committerLuis Martinez2021-09-12 00:05:21 -0500
commitb4111b101540b6da4ffb546d303b35b3be20dd06 (patch)
treea925ff3ae13f65e5f034fe61d5597a93348d2f99
downloadaur-b4111b101540b6da4ffb546d303b35b3be20dd06.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--CHANGES.rst142
-rw-r--r--PKGBUILD30
3 files changed, 187 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..429a0e4e077e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-quicktions
+ pkgdesc = Fast fractions implementation in Cython
+ pkgver = 1.11
+ pkgrel = 1
+ url = https://github.com/scoder/quicktions
+ changelog = CHANGES.rst
+ arch = x86_64
+ license = Python
+ makedepends = python-setuptools
+ makedepends = cython
+ depends = glibc
+ source = python-quicktions-1.11.tar.gz::https://github.com/scoder/quicktions/archive/1.11.tar.gz
+ sha256sums = 7a6c9af50860731a53e48d9fc8547e1d202069e0d01afc2f557dabd7d043b006
+
+pkgname = python-quicktions
diff --git a/CHANGES.rst b/CHANGES.rst
new file mode 100644
index 000000000000..a52798c52b50
--- /dev/null
+++ b/CHANGES.rst
@@ -0,0 +1,142 @@
+ChangeLog
+=========
+
+1.11 (2019-12-??)
+-----------------
+
+* Fix ``OverflowError`` when parsing string values with long decimal parts.
+
+
+1.10 (2019-08-23)
+-----------------
+
+* ``hash(fraction)`` is substantially faster in Py3.8+, following an optimisation
+ in CPython 3.9 (https://bugs.python.org/issue37863).
+
+* New method ``fraction.as_integer_ratio()``.
+
+
+1.9 (2018-12-26)
+----------------
+
+* Substantially faster normalisation (and therefore instantiation) in Py3.5+.
+
+* ``//`` (floordiv) now follows the expected rounding behaviour when used with
+ floats (by converting to float first), and is much faster for integer operations.
+
+* Fix return type of divmod(), where the first item should be an integer.
+
+* Further speed up mod and divmod operations.
+
+
+1.8 (2018-12-26)
+----------------
+
+* Faster mod and divmod calculation.
+
+
+1.7 (2018-10-16)
+----------------
+
+* Faster normalisation and fraction string parsing.
+
+* Add support for Python 3.7.
+
+* Built using Cython 0.29.
+
+
+1.6 (2018-03-23)
+----------------
+
+* Speed up Fraction creation from a string value by 3-5x.
+
+* Built using Cython 0.28.1.
+
+
+1.5 (2017-10-22)
+----------------
+
+* Result of power operator (``**``) was not normalised for negative values.
+
+* Built using Cython 0.27.2.
+
+
+1.4 (2017-09-16)
+----------------
+
+* Rebuilt using Cython 0.26.1 to improve support of Python 3.7.
+
+
+1.3 (2016-07-24)
+----------------
+
+* repair the faster instantiation from Decimal values in Python 3.6
+
+* avoid potential glitch for certain large numbers in normalisation under Python 2.x
+
+
+1.2 (2016-04-08)
+----------------
+
+* change hash function in Python 2.x to match that of ``fractions.Fraction``
+
+
+1.1 (2016-03-29)
+----------------
+
+* faster instantiation from float values
+
+* faster instantiation from Decimal values in Python 3.6
+
+
+1.0 (2015-09-10)
+----------------
+
+* ``Fraction.imag`` property could return non-zero
+
+* parsing strings with long fraction parts could use an incorrect scale
+
+
+0.7 (2014-10-09)
+----------------
+
+* faster instantiation from float and string values
+
+* fix test in Python 2.x
+
+
+0.6 (2014-10-09)
+----------------
+
+* faster normalisation (and thus instantiation)
+
+
+0.5 (2014-10-06)
+----------------
+
+* faster math operations
+
+
+0.4 (2014-10-06)
+----------------
+
+* enable legacy division support in Python 2.x
+
+
+0.3 (2014-10-05)
+----------------
+
+* minor behavioural fixes in corner cases under Python 2.x
+ (now passes all test in Py2.7 as well)
+
+
+0.2 (2014-10-03)
+----------------
+
+* cache hash value of Fractions
+
+
+0.1 (2014-09-24)
+----------------
+
+* initial public release
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d70a37c78079
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=python-quicktions
+pkgver=1.11
+pkgrel=1
+pkgdesc="Fast fractions implementation in Cython"
+arch=('x86_64')
+url="https://github.com/scoder/quicktions"
+license=('Python')
+depends=('glibc')
+makedepends=('python-setuptools' 'cython')
+changelog=CHANGES.rst
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('7a6c9af50860731a53e48d9fc8547e1d202069e0d01afc2f557dabd7d043b006')
+
+build() {
+ cd "quicktions-$pkgver"
+ make
+}
+
+check() {
+ cd "quicktions-$pkgver"
+ make test
+}
+
+package() {
+ cd "quicktions-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+}