summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRay Ganardi2023-01-04 14:14:40 +0100
committerRay Ganardi2023-01-04 14:14:40 +0100
commit6ae753e27216ab3cab3c98323c4c42e5a454279f (patch)
treed25668260a24e1939b231a3068fe5dc527b19833
parent19f8c3aa052c1ce157a3e7e70ece82c70e730ea4 (diff)
downloadaur-6ae753e27216ab3cab3c98323c4c42e5a454279f.tar.gz
Update to version 4.7.1
Run tests in check
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 693cba892e49..8584c8ae412a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-qutip
pkgdesc = QuTiP is open-source software for simulating the dynamics of open quantum systems
- pkgver = 4.7.0
+ pkgver = 4.7.1
pkgrel = 1
url = http://qutip.org/index.html
arch = x86_64
@@ -17,7 +17,7 @@ pkgbase = python-qutip
optdepends = python-nose: Optional, For running tests.
optdepends = python-scikit-umfpack: Optional, Faster (~2-5x) steady state calculations.
optdepends = openmp: Optional, For OPENMP support
- source = https://github.com/qutip/qutip/archive/v4.7.0.tar.gz
- md5sums = a2c0721e37dda0925eaecc43dc0079fc
+ source = https://github.com/qutip/qutip/archive/v4.7.1.tar.gz
+ md5sums = 1618b509fa12121337916dd81cc4ffad
pkgname = python-qutip
diff --git a/PKGBUILD b/PKGBUILD
index 5555be14afbd..6c3458e89841 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_name=qutip
_pkgname=qutip
pkgname=python-qutip
-pkgver=4.7.0
+pkgver=4.7.1
pkgrel=1
pkgdesc="QuTiP is open-source software for simulating the dynamics of open quantum systems"
arch=("x86_64")
@@ -23,7 +23,7 @@ optdepends=(
)
source=("https://github.com/qutip/qutip/archive/v$pkgver.tar.gz")
-md5sums=('a2c0721e37dda0925eaecc43dc0079fc')
+md5sums=('1618b509fa12121337916dd81cc4ffad')
build() {
cd "$srcdir/$_pkgname-$pkgver"
@@ -39,3 +39,12 @@ package() {
python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
install -D -m644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
+
+check() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$PWD/tmp_install" --optimize=1
+ cd "$PWD/tmp_install"
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ PATH="$PWD/usr/bin:$PATH" PYTHONPATH="$PWD$site_packages:$PYTHONPATH" python -c 'import qutip.testing; qutip.testing.run()'
+
+}