summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRay Ganardi2021-02-22 10:48:23 +0100
committerRay Ganardi2021-02-22 10:48:23 +0100
commitee14acce0203a7e5df9572790030c5cfc4443e6c (patch)
tree862206c05410cc9ea4c001b58641e339f70fe090
parent94f9382073f1da7c2cec1fafe249063052c2e28e (diff)
downloadaur-ee14acce0203a7e5df9572790030c5cfc4443e6c.tar.gz
Update to version 4.5.3
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc9ca9753a6e..6b2c2c4ab02d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-qutip
pkgdesc = QuTiP is open-source software for simulating the dynamics of open quantum systems
- pkgver = 4.5.0
+ pkgver = 4.5.3
pkgrel = 1
url = http://qutip.org/index.html
arch = x86_64
@@ -17,8 +17,8 @@ pkgbase = python-qutip
optdepends = python-nose: Optional, For running tests.
optdepends = python-scikit-umfpack: Optional, Faster (~2-5x) steady state calculations.
optdepends = openmp: Optional, For OPENMP support
- source = http://qutip.org/downloads/4.5.0/qutip-4.5.0.tar.gz
- md5sums = 6ed49db07cc092c88a6853b5a27971ee
+ source = https://github.com/qutip/qutip/archive/v4.5.3.tar.gz
+ md5sums = d88105378fec0dfb6e877375dd8db262
pkgname = python-qutip
diff --git a/PKGBUILD b/PKGBUILD
index 7a2565bc02ee..3a2d268bce8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_name=qutip
_pkgname=qutip
pkgname=python-qutip
-pkgver=4.5.0
+pkgver=4.5.3
pkgrel=1
pkgdesc="QuTiP is open-source software for simulating the dynamics of open quantum systems"
arch=("x86_64")
@@ -22,12 +22,12 @@ optdepends=(
"openmp: Optional, For OPENMP support"
)
-source=("http://qutip.org/downloads/$pkgver/$_name-$pkgver.tar.gz")
-md5sums=('6ed49db07cc092c88a6853b5a27971ee')
+source=("https://github.com/qutip/qutip/archive/v$pkgver.tar.gz")
+md5sums=('d88105378fec0dfb6e877375dd8db262')
build() {
cd "$srcdir/$_pkgname-$pkgver"
- if pacman -Qq openmp 2&>1 > /dev/null; then
+ if pacman -Qq openmp &> /dev/null; then
python setup.py build --with-openmp
else
python setup.py build