summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMcNoggins2015-08-27 20:19:56 -0400
committerMcNoggins2015-08-27 20:19:56 -0400
commitf2edb20cdc54b9198d86568667ae13591ebbf6b5 (patch)
treede4d90aa6792f4c1362aac4da6768283c8ab8ad8
downloadaur-f2edb20cdc54b9198d86568667ae13591ebbf6b5.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c5837a06303b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-qutip
+ pkgdesc = QuTiP is open-source software for simulating the dynamics of open quantum systems
+ pkgver = 3.1.0
+ pkgrel = 1
+ url = http://qutip.org/index.html
+ arch = any
+ license = GPL3
+ makedepends = cython
+ makedepends = gcc-fortran
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-matplotlib
+ optdepends = mayavi: Optional. Needed for using the Bloch3d class
+ optdepends = python-pyqt4: Optional, required only for GUI elements
+ optdepends = texlive-bin: Optional. Needed if using LaTeX in figures
+ source = http://qutip.org/downloads/3.1.0/qutip-3.1.0.tar.gz
+ md5sums = 73aefdc714149fa6e1a03de660f2eb2b
+
+pkgname = python-qutip
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cbd0386ea033
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Andres F. Urquijo <alfagalileox@gmail.com>
+_name=qutip
+_pkgname=qutip
+pkgname=python-qutip
+pkgver=3.1.0
+pkgrel=1
+pkgdesc="QuTiP is open-source software for simulating the dynamics of open quantum systems"
+arch=("any")
+url="http://qutip.org/index.html"
+license=('GPL3')
+depends=("python-numpy" "python-scipy" "python-matplotlib")
+makedepends=("cython" "gcc-fortran")
+optdepends=(
+ "mayavi: Optional. Needed for using the Bloch3d class"
+ "python-pyqt4: Optional, required only for GUI elements"
+ "texlive-bin: Optional. Needed if using LaTeX in figures"
+)
+
+source=("http://qutip.org/downloads/$pkgver/$_name-$pkgver.tar.gz")
+md5sums=('73aefdc714149fa6e1a03de660f2eb2b')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
+}