summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2016-10-21 17:56:19 +0200
committerChristopher Arndt2016-10-21 17:56:19 +0200
commita3dabf9774968982ff38f6f992ac68438e1010ee (patch)
tree6149b35b3598df9752e27b70739d333fc1a88431
parent962bdc3fa3fa292495088d75277e559b61f6e33f (diff)
downloadaur-a3dabf9774968982ff38f6f992ac68438e1010ee.tar.gz
Update to upstream version 1.4.2; add Python 2 package; patch away Python dependency pinning; install license
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore1
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD63
4 files changed, 89 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b0624858e6d..73f383f1977b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,27 @@
# Generated by mksrcinfo v8
-# Sat Jun 25 12:57:18 UTC 2016
+# Fri Oct 21 15:54:13 UTC 2016
pkgbase = python-radon
- pkgdesc = A tool that computes various metrics for Python source code.
- pkgver = 1.4.0
+ pkgver = 1.4.2
pkgrel = 1
url = https://radon.readthedocs.org/
arch = any
license = MIT
makedepends = python-sphinx
+ makedepends = python2-sphinx
+ source = https://pypi.python.org/packages/91/48/5853fa60811d6cec1043bd60b057aafc22706e19ab90b33d8df8155e6b8d/radon-1.4.2.tar.gz
+ source = https://raw.githubusercontent.com/rubik/radon/master/LICENSE
+ sha256sums = 4f24ea6215e17c7c6d8548035c56d29e31131d17da1d607359fc07e9b6fabe97
+ sha256sums = 13cde2df14c3b42e6ecd452dd2b4d679ac40e7cbaaa8d2d87068f1e46be53677
+
+pkgname = python-radon
+ pkgdesc = A tool that computes various metrics for Python source code
+ depends = python-flake8-polyfill
depends = python-mando
depends = python-colorama
- source = https://pypi.python.org/packages/99/f9/31a0a3eb9e63bd8e3a3c44b4c676bf051ec05273ed09dcf00695ee8df318/radon-1.4.0.tar.gz
- md5sums = 52d5ab0564ceff5edb9b38d8c49cf544
-pkgname = python-radon
+pkgname = python2-radon
+ pkgdesc = A tool that computes various metrics for Python source code (Python2)
+ depends = python2-flake8-polyfill
+ depends = python2-mando
+ depends = python2-colorama
diff --git a/.gitignore b/.gitignore
index 933b844a7660..9e40f441bf92 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,5 +2,6 @@ pkg
src
radon-*.tar.gz
python-radon-*.pkg.tar.xz
+python2-radon-*.pkg.tar.xz
python-radon-*.src.tar.gz
.AURINFO
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..bd888528d35e
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+Copyright (c) 2012-2014 Michele Lacchia
+
+Permission is hereby granted, free of charge, to any person
+obtaining a copy of this software and associated documentation
+files (the "Software"), to deal in the Software without
+restriction, including without limitation the rights to use,
+copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the
+Software is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
+OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 6b6eb18317ed..d1be87ab04ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,68 @@
# Contributor: Simon Conseil <contact+aur at saimon dot org>
# Contributor: Jesus Alvarez
-pkgname=python-radon
-pkgver=1.4.0
+_module=radon
+pkgbase="python-${_module}"
+pkgname=("${pkgbase}" "python2-${_module}")
+pkgver=1.4.2
pkgrel=1
-pkgdesc="A tool that computes various metrics for Python source code."
arch=('any')
url="https://radon.readthedocs.org/"
license=('MIT')
-depends=('python-mando' 'python-colorama')
-makedepends=('python-sphinx')
-source=("https://pypi.python.org/packages/99/f9/31a0a3eb9e63bd8e3a3c44b4c676bf051ec05273ed09dcf00695ee8df318/radon-1.4.0.tar.gz")
-md5sums=('52d5ab0564ceff5edb9b38d8c49cf544')
+depends=()
+makedepends=('python-sphinx' 'python2-sphinx')
+source=("https://pypi.python.org/packages/91/48/5853fa60811d6cec1043bd60b057aafc22706e19ab90b33d8df8155e6b8d/${_module}-${pkgver}.tar.gz"
+ "https://raw.githubusercontent.com/rubik/radon/master/LICENSE"
+)
+sha256sums=('4f24ea6215e17c7c6d8548035c56d29e31131d17da1d607359fc07e9b6fabe97'
+ '13cde2df14c3b42e6ecd452dd2b4d679ac40e7cbaaa8d2d87068f1e46be53677')
+prepare() {
+ cp -r ${_module}-${pkgver} python2-${_module}-${pkgver}
+}
+
build() {
- cd "$srcdir/radon-$pkgver/docs"
+ cd "${srcdir}/${_module}-${pkgver}"
+ sed -i -e "s/mando[^']*/mando/" -e "s/colorama[^']*/colorama/" setup.py
+ python setup.py build
+ cd docs
+ make html
+ cd "${srcdir}/python2-${_module}-${pkgver}"
+ sed -i -e "s/mando[^']*/mando/" -e "s/colorama[^']*/colorama/" setup.py
+ python2 setup.py build
+ cd docs
make html
}
-package() {
- cd "$srcdir/radon-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+package_python-radon() {
+ pkgdesc="A tool that computes various metrics for Python source code"
+ depends=('python-flake8-polyfill' 'python-mando' 'python-colorama')
+
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="$pkgdir" --skip-build --optimize=1
+
+ install -d "${pkgdir}/usr/share/doc/${pkgname}"
+ cp -r docs/_build/html/* "${pkgdir}/usr/share/doc/${pkgname}"
+
+ # license
+ install -Dm644 ${srcdir}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+package_python2-radon() {
+ pkgdesc="A tool that computes various metrics for Python source code (Python2)"
+ depends=('python2-flake8-polyfill' 'python2-mando' 'python2-colorama')
+
+ cd "${srcdir}/python2-${_module}-$pkgver"
+ python2 setup.py install --root="$pkgdir" --skip-build --optimize=1
+ mv "$pkgdir/usr/bin/radon" "$pkgdir/usr/bin/radon2"
+
+ install -d "${pkgdir}/usr/share/doc/${pkgname}"
+ cp -r docs/_build/html/* "${pkgdir}/usr/share/doc/${pkgname}"
- install -d "$pkgdir/usr/share/doc/$pkgname"
- cp -r docs/_build/html/* "$pkgdir/usr/share/doc/$pkgname"
+ # license
+ install -Dm644 ${srcdir}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
# vim:set ts=2 sw=2 et: