summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2022-05-07 15:41:33 +0300
committerPekka Ristola2022-05-07 15:41:48 +0300
commitb70f7de14b5520ec70e243a9e4929dd1a0ead484 (patch)
tree92649c0caf96b2fc7532fce698e689c19fe2f96c
parentbcab40578fde10de6c0de8ee482d42ce2ee8a680 (diff)
downloadaur-b70f7de14b5520ec70e243a9e4929dd1a0ead484.tar.gz
Update to v2.0.11
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD12
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 145dbed0e130..1f02f05cfd74 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = python-rapidfuzz
- pkgdesc = Rapid fuzzy string matching in Python and C++ using the Levenshtein Distance
- pkgver = 2.0.9
+ pkgdesc = Rapid fuzzy string matching in Python using various string metrics
+ pkgver = 2.0.11
pkgrel = 1
url = https://github.com/maxbachmann/rapidfuzz
arch = x86_64
license = MIT
+ makedepends = git
+ makedepends = jarowinkler-cpp
makedepends = python-numpy
makedepends = python-rapidfuzz-capi
makedepends = python-scikit-build
makedepends = python-setuptools
+ makedepends = rapidfuzz-cpp
depends = python-jarowinkler
optdepends = python-numpy
- source = https://files.pythonhosted.org/packages/source/r/rapidfuzz/rapidfuzz-2.0.9.tar.gz
- sha256sums = c5ac9477bc7479799ef81d5bb02e657503eda5241490fd6f632a8db5e4a29639
+ source = https://files.pythonhosted.org/packages/source/r/rapidfuzz/rapidfuzz-2.0.11.tar.gz
+ sha256sums = 934b65fea75e3bd310d74903ec69ff3df061b3058ab5b7f49ab772958109bca8
pkgname = python-rapidfuzz
diff --git a/PKGBUILD b/PKGBUILD
index 6e7ae052a2c1..91b52d903931 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,29 @@
_pkgname='rapidfuzz'
pkgname="python-${_pkgname}"
-pkgver=2.0.9
+pkgver=2.0.11
pkgrel=1
-pkgdesc='Rapid fuzzy string matching in Python and C++ using the Levenshtein Distance'
+pkgdesc='Rapid fuzzy string matching in Python using various string metrics'
arch=('x86_64')
url='https://github.com/maxbachmann/rapidfuzz'
license=('MIT')
depends=('python-jarowinkler')
makedepends=(
+ 'git'
+ 'jarowinkler-cpp'
'python-numpy'
'python-rapidfuzz-capi'
'python-scikit-build'
'python-setuptools'
+ 'rapidfuzz-cpp'
)
optdepends=('python-numpy')
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('c5ac9477bc7479799ef81d5bb02e657503eda5241490fd6f632a8db5e4a29639')
+sha256sums=('934b65fea75e3bd310d74903ec69ff3df061b3058ab5b7f49ab772958109bca8')
build() {
cd "${_pkgname}-${pkgver}"
+ # Use vendored version of Taskflow until cpp-taskflow package is fixed
python setup.py build \
-G "Unix Makefiles" \
--build-type None \
@@ -31,8 +35,6 @@ build() {
package() {
cd "${_pkgname}-${pkgver}"
python setup.py --skip-cmake install --root="$pkgdir" --optimize=1 --skip-build
- # remove unnecessary files (upstream issue #201)
- rm -r "$pkgdir/usr/include"
install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}"
install -Dvm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}"