summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-04-15 10:30:13 -0600
committerMark Wagie2022-04-15 10:30:13 -0600
commit55e4c5adb632215b64a8fb46253f080d8beaf1c4 (patch)
tree9e5f3b0f5706f4659da7f22a7a53accd544952c8
parentb8a9b74feba5055d59677c9e1f2e520ae5c9b6dd (diff)
downloadaur-55e4c5adb632215b64a8fb46253f080d8beaf1c4.tar.gz
standards based build
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59e0bbd5c727..b552bb935d98 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = python-rarfile
pkgdesc = Python module for RAR archive reading
pkgver = 4.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/markokr/rarfile
arch = any
license = ISC
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python
optdepends = unarchiver: alternative decompression backend
optdepends = libarchive: alternative decompression backend
diff --git a/PKGBUILD b/PKGBUILD
index fa233f5e3aa2..a5eb0b5be00c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=python-rarfile
_name=${pkgname#python-}
pkgver=4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Python module for RAR archive reading"
arch=('any')
url="https://github.com/markokr/rarfile"
license=('ISC')
depends=('python')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
optdepends=('unarchiver: alternative decompression backend'
'libarchive: alternative decompression backend'
'python-crypto: process archives with password-protected headers')
@@ -19,12 +19,12 @@ sha256sums=('67548769229c5bda0827c1663dce3f54644f9dbfba4ae86d4da2b2afd3e602a1')
build() {
cd "$_name-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$_name-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}