summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSébastien Leduc2016-05-05 18:37:13 +0200
committerSébastien Leduc2016-05-05 18:37:13 +0200
commit89096d881888bad30c8feb79eab01c930e9c2c86 (patch)
tree4fc2cd17d121061d01c1b8ce8d041ec293701243
downloadaur-89096d881888bad30c8feb79eab01c930e9c2c86.tar.gz
Initial commit for python-rarfile
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD43
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33d0f469c325
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# jeu. mai 5 16:36:41 UTC 2016
+pkgbase = python-rarfile
+ pkgdesc = Rar archive reader for Python
+ pkgver = 2.7
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/rarfile
+ arch = any
+ license = custom:ISC
+ makedepends = python
+ makedepends = python-docutils
+ makedepends = python-sphinx
+ depends = python
+ optdepends = unrar: Decompressing compressed files
+ optdepends = libarchive: Alternative to "unrar"
+ optdepends = python-crypto: Parsing encrypted headers
+ provides = python-rarfile
+ source = https://pypi.python.org/packages/source/r/rarfile/rarfile-2.7.tar.gz
+ md5sums = d143205f22078830451e0066c123580d
+
+pkgname = python-rarfile
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..841c2cb73c6e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Sebastien Leduc <sebastien@sleduc.fr>
+# Contributor: Cedric Girard <girard.cedric@gmail.com>
+
+_proj=rarfile
+#_python=python2 _pyver=2
+_python=python _pyver=""
+pkgname="$_python-$_proj"
+pkgver=2.7
+pkgrel=1
+pkgdesc="Rar archive reader for Python"
+arch=(any)
+url="https://pypi.python.org/pypi/$_proj"
+license=(custom:ISC)
+makedepends=("python$_pyver")
+
+# These only required to build the documentation:
+makedepends+=(python-docutils "python$_pyver-sphinx")
+
+depends=("python$_pyver")
+optdepends=(
+ "unrar: Decompressing compressed files"
+ 'libarchive: Alternative to "unrar"'
+ "python$_pyver-crypto: Parsing encrypted headers"
+)
+provides=("python-$_proj")
+source=(
+ "https://pypi.python.org/packages/source/r/$_proj/$_proj-$pkgver.tar.gz"
+)
+md5sums=(d143205f22078830451e0066c123580d)
+
+build() {
+ cd "$srcdir/$_proj-$pkgver"
+ "$_python" setup.py build
+ make html SPHINXBUILD="sphinx-build$_pyver" BUILDDIR="_build-$pkgname"
+}
+
+package() {
+ cd "$srcdir/$_proj-$pkgver"
+ "$_python" setup.py install --root="$pkgdir" --optimize=1
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 README.html "$pkgdir/usr/share/doc/$pkgname/README.html"
+ cp -a "doc/_build-$pkgname/html" "$pkgdir/usr/share/doc/$pkgname/"
+}