summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDevaev Maxim2019-02-11 00:31:06 +0300
committerDevaev Maxim2019-02-11 00:31:06 +0300
commitee17668da52a231beb81823f65ca8f8ea09fee6b (patch)
tree6475f1d818164bc5b4f764bfc5889c3c058a9fbf
parent48080db1e65be6bd3411044011a924bd88f1f323 (diff)
downloadaur-ee17668da52a231beb81823f65ca8f8ea09fee6b.tar.gz
Update to 0.6.5-1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca2229322ad4..2defc78698aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
-# Generated by mksrcinfo v8
-# Sun Sep 3 19:27:20 UTC 2017
pkgbase = python-raspberry-gpio
pkgdesc = Python library for GPIO access on a Raspberry Pi
- pkgver = 0.6.3
+ pkgver = 0.6.5
pkgrel = 1
url = http://sourceforge.net/projects/raspberry-gpio-python/
arch = armv6h
arch = armv7h
arch = aarch64
license = MIT
+ makedepends = gcc
makedepends = python-distribute
depends = python
- source = https://files.pythonhosted.org/packages/source/R/RPi.GPIO/RPi.GPIO-0.6.3.tar.gz
- md5sums = e4abe1cfb5eacebe53078032256eb837
+ source = https://files.pythonhosted.org/packages/source/R/RPi.GPIO/RPi.GPIO-0.6.5.tar.gz
+ sha1sums = b792e7b95e3a169b35ea9010fc8bd3e5d69aa670
pkgname = python-raspberry-gpio
diff --git a/PKGBUILD b/PKGBUILD
index 62a245bd1b77..0a4ea08d4a8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
# Contributor: Michael Serpieri <contact at pygoscelis dot org>
-pkgname="python-raspberry-gpio"
-pkgver="0.6.3"
-pkgrel="1"
+pkgname=python-raspberry-gpio
+pkgver=0.6.5
+pkgrel=1
pkgdesc="Python library for GPIO access on a Raspberry Pi"
-arch=("armv6h" "armv7h" "aarch64")
url="http://sourceforge.net/projects/raspberry-gpio-python/"
-license=("MIT")
-depends=("python")
-makedepends=("python-distribute")
+license=(MIT)
+arch=(armv6h armv7h aarch64)
+depends=(python)
+makedepends=(gcc python-distribute)
source=("https://files.pythonhosted.org/packages/source/R/RPi.GPIO/RPi.GPIO-$pkgver.tar.gz")
-md5sums=("e4abe1cfb5eacebe53078032256eb837")
+sha1sums=(b792e7b95e3a169b35ea9010fc8bd3e5d69aa670)
package() {
- cd $srcdir/RPi.GPIO-$pkgver
- python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+ cd "$srcdir/RPi.GPIO-$pkgver"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
}