summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2021-11-19 09:39:55 -0500
committerGuillaume Horel2021-11-19 09:39:55 -0500
commite031a9bf97cd5fafc5b9493078b69b758b04c9ce (patch)
tree7ab2a92c317de4bfd9ec8a8d96fbb5e049d2eb6e
downloadaur-e031a9bf97cd5fafc5b9493078b69b758b04c9ce.tar.gz
initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d5298c7f7ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-ratelimit
+ pkgdesc = API rate limit decorator
+ pkgver = 2.2.1
+ pkgrel = 1
+ url = https://github.com/tomasbasham/ratelimit
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://pypi.org/packages/source/r/ratelimit/ratelimit-2.2.1.tar.gz
+ sha256sums = af8a9b64b821529aca09ebaf6d8d279100d766f19e90b5059ac6a718ca6dee42
+
+pkgname = python-ratelimit
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b69b32f584da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+
+pkgname=python-ratelimit
+_pkgname=ratelimit
+pkgver=2.2.1
+pkgrel=1
+pkgdesc="API rate limit decorator"
+arch=('any')
+url="https://github.com/tomasbasham/ratelimit"
+license=('MIT')
+depends=('python')
+optdepends=()
+makedepends=('python-setuptools')
+source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('af8a9b64b821529aca09ebaf6d8d279100d766f19e90b5059ac6a718ca6dee42')
+
+build(){
+ cd "$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package(){
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+
+## vim:ts=2:sw=2:et: