summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTroy C2015-06-25 12:03:40 -0500
committerTroy C2015-06-25 12:03:40 -0500
commit6f0242c0f9e79d7d770094bd646d34f792bb97ff (patch)
tree261ba3280242b196b46ad37e727bf1650b7fac04
downloadaur-6f0242c0f9e79d7d770094bd646d34f792bb97ff.tar.gz
Initial commit to AUR4
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e65e2306684
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-rax-scheduled-images-python-novaclient-ext
+ pkgdesc = Extends python-novaclient to use RAX-SI, the Rackspace Nova API Scheduled Images extension
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/rax_scheduled_images_python_novaclient_ext
+ arch = any
+ license = GPL
+ makedepends = python2-setuptools
+ depends = python2-novaclient
+ provides = python2-rax-scheduled-images-python-novaclient-ext=0.2.2
+ source = http://pypi.python.org/packages/source/r/rax_scheduled_images_python_novaclient_ext/rax_scheduled_images_python_novaclient_ext-0.2.2.tar.gz
+ md5sums = 9d9507aa4b42164169c62ee2057ece08
+
+pkgname = python2-rax-scheduled-images-python-novaclient-ext
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8ee80398e7c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Troy C < rstrox -ta yahoo -tod com >
+
+pkgname=python2-rax-scheduled-images-python-novaclient-ext
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="Extends python-novaclient to use RAX-SI, the Rackspace Nova API Scheduled Images extension"
+arch=('any')
+url="http://pypi.python.org/pypi/rax_scheduled_images_python_novaclient_ext"
+license=('GPL')
+depends=('python2-novaclient')
+makedepends=('python2-setuptools')
+provides=("$pkgname=$pkgver")
+source=(http://pypi.python.org/packages/source/r/rax_scheduled_images_python_novaclient_ext/rax_scheduled_images_python_novaclient_ext-${pkgver}.tar.gz)
+md5sums=('9d9507aa4b42164169c62ee2057ece08')
+
+build() {
+ cd "$srcdir/rax_scheduled_images_python_novaclient_ext-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/rax_scheduled_images_python_novaclient_ext-$pkgver"
+ python2 setup.py install --root=${pkgdir}
+}