summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-06-25 18:49:34 -0400
committeracxz2020-06-25 18:49:34 -0400
commit02c84d323e19efe949d8a3633eda61b0ed3b434a (patch)
treea24ac87d4bb76ee82f5523289a04b2ba127c034b
parentccf4b39f44930913712fc94c6ff8a27726562cab (diff)
downloadaur-02c84d323e19efe949d8a3633eda61b0ed3b434a.tar.gz
updpkg 0.8.6
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD20
2 files changed, 26 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16a39206a1f3..ac610982a732 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-ray
pkgdesc = A fast and simple framework for building and running distributed applications.
- pkgver = 0.8.5
+ pkgver = 0.8.6
pkgrel = 1
url = https://ray.io
arch = x86_64
@@ -13,30 +13,27 @@ pkgbase = python-ray
makedepends = bazel
depends = psmisc
depends = python
- depends = python-numpy
- depends = python-filelock
- depends = python-jsonschema
+ depends = python-aiohttp
depends = python-click
depends = python-colorama
- depends = python-packaging
- depends = python-pytest
- depends = python-pyaml
- depends = python-redis
- depends = python-six
- depends = python-protobuf
- depends = python-cloudpickle
- depends = py-spy
- depends = python-aiohttp
+ depends = python-filelock
depends = python-google
depends = python-grpcio
+ depends = python-jsonschema
+ depends = python-msgpack
+ depends = python-numpy
+ depends = python-protobuf
+ depends = py-spy
+ depends = python-pyaml
+ depends = python-redis
+ optdepends = python-requests: for ray[dashboard] module
+ optdepends = python-gpustat: for ray[dashboard] module
optdepends = uvicorn: for ray[serve] module
- optdepends = python-pygments: for ray[serve] module
- optdepends = python-werkzeug: for ray[serve] module
optdepends = python-flask: for ray[serve] module
- optdepends = python-pandas: for ray[serve] module
- optdepends = python-blist: for ray[serve] module
+ optdepends = python-blist: for ray[server] module
optdepends = python-tabulate: for ray[tune] and ray[rllib] module
optdepends = python-tensorboardx: for ray[tune] and ray[rllib] module
+ optdepends = python-pandas: for ray[tune] and ray[rllib] module
optdepends = python-atari-py: for ray[rllib] module
optdepends = python-dm-tree: for ray[rllib] module
optdepends = python-gym: for ray[rllib] module
@@ -45,8 +42,8 @@ pkgbase = python-ray
optdepends = python-pyaml: for ray[rllib] module
optdepends = python-scipy: for ray[rllib] module
optdepends = python-msgpack: for ray[streaming] module
- source = ray-0.8.5::https://github.com/ray-project/ray/archive/ray-0.8.5.tar.gz
- sha256sums = 47622e70dc297805a547e935ba8890c1280c4394e6f55670c1929a3088beb793
+ source = ray-0.8.6::https://github.com/ray-project/ray/archive/ray-0.8.6.tar.gz
+ sha256sums = c0366e3911f6b4f9eec1aae7969c12882df9bcf408bbcdc1fceb18f3b303543c
pkgname = python-ray
diff --git a/PKGBUILD b/PKGBUILD
index 909994e7a123..43f598774688 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=python-ray
-pkgver=0.8.5
+pkgver=0.8.6
pkgrel=1
pkgdesc='A fast and simple framework for building and running distributed
applications.'
arch=('x86_64')
url='https://ray.io'
license=('Apache-2.0')
-depends=(psmisc python python-numpy python-filelock python-jsonschema
- python-click python-colorama python-packaging python-pytest python-pyaml
- python-redis python-six python-protobuf python-cloudpickle py-spy
- python-aiohttp python-google python-grpcio)
+depends=(psmisc python python-aiohttp python-click python-colorama
+ python-filelock python-google python-grpcio python-jsonschema
+ python-msgpack python-numpy python-protobuf py-spy python-pyaml
+ python-redis)
optdepends=(
+ 'python-requests: for ray[dashboard] module'
+ 'python-gpustat: for ray[dashboard] module'
'uvicorn: for ray[serve] module'
- 'python-pygments: for ray[serve] module'
- 'python-werkzeug: for ray[serve] module'
'python-flask: for ray[serve] module'
- 'python-pandas: for ray[serve] module'
- 'python-blist: for ray[serve] module'
+ 'python-blist: for ray[server] module'
'python-tabulate: for ray[tune] and ray[rllib] module'
'python-tensorboardx: for ray[tune] and ray[rllib] module'
+ 'python-pandas: for ray[tune] and ray[rllib] module'
'python-atari-py: for ray[rllib] module'
'python-dm-tree: for ray[rllib] module'
'python-gym: for ray[rllib] module'
@@ -33,7 +33,7 @@ optdepends=(
makedepends=(python python-setuptools python-wheel python-pip cython bazel)
_pkgname=ray
source=("${_pkgname}-${pkgver}::https://github.com/ray-project/ray/archive/${_pkgname}-$pkgver.tar.gz")
-sha256sums=('47622e70dc297805a547e935ba8890c1280c4394e6f55670c1929a3088beb793')
+sha256sums=('c0366e3911f6b4f9eec1aae7969c12882df9bcf408bbcdc1fceb18f3b303543c')
build() {
cd "${srcdir}/${_pkgname}-${_pkgname}-${pkgver}/python"