summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-12-24 13:30:26 -0500
committeracxz2020-12-24 13:30:26 -0500
commitfe4f644daad3740e764cd6e84889a37cae228e7a (patch)
tree3b4e22373db5b52b6c3805e5c639921189c22ed1
parent7f85beb7fa0955050819a8a648b425448cd32b1d (diff)
downloadaur-fe4f644daad3740e764cd6e84889a37cae228e7a.tar.gz
updpkg 1.1.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13c8e9cc5b84..39e68bfd608c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-ray
pkgdesc = A fast and simple framework for building and running distributed applications.
- pkgver = 1.0.1
- pkgrel = 2
+ pkgver = 1.1.0
+ pkgrel = 1
url = https://ray.io
arch = x86_64
license = Apache-2.0
@@ -47,10 +47,8 @@ pkgbase = python-ray
optdepends = opencv: for ray[rllib] module
optdepends = python-pyaml: for ray[rllib] module
optdepends = python-scipy: for ray[rllib] module
- source = python-ray-1.0.1.tar.gz::https://github.com/ray-project/ray/archive/ray-1.0.1.tar.gz
- source = redis-py.patch::https://patch-diff.githubusercontent.com/raw/ray-project/ray/pull/11776.patch
- sha256sums = e08ff04dc8bca99527dbc821446f8660cfe6cbc8c35db61410958b9aa9acee56
- sha256sums = SKIP
+ source = python-ray-1.1.0.tar.gz::https://github.com/ray-project/ray/archive/ray-1.1.0.tar.gz
+ sha256sums = c0fde1b6df563d8875e40aa12ad7559863753a3f7e11c976fea6d67d4adcb26c
pkgname = python-ray
diff --git a/PKGBUILD b/PKGBUILD
index 02b06cfb5db6..27d1ed11bf87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=python-ray
-pkgver=1.0.1
-pkgrel=2
+pkgver=1.1.0
+pkgrel=1
pkgdesc='A fast and simple framework for building and running distributed
applications.'
arch=('x86_64')
@@ -31,17 +31,12 @@ optdepends=(
)
makedepends=(python python-setuptools python-wheel python-pip cython bazel)
_pkgname=ray
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ray-project/ray/archive/${_pkgname}-$pkgver.tar.gz"
- "redis-py.patch::https://patch-diff.githubusercontent.com/raw/ray-project/ray/pull/11776.patch")
-sha256sums=('e08ff04dc8bca99527dbc821446f8660cfe6cbc8c35db61410958b9aa9acee56'
- 'SKIP')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ray-project/ray/archive/${_pkgname}-$pkgver.tar.gz")
+sha256sums=('c0fde1b6df563d8875e40aa12ad7559863753a3f7e11c976fea6d67d4adcb26c')
prepare() {
cd "${srcdir}/${_pkgname}-${_pkgname}-${pkgver}"
- # https://github.com/ray-project/ray/pull/11776
- patch -Np1 -i "${srcdir}"/redis-py.patch
-
# https://github.com/ray-project/ray/pull/12613
sed -i "s/8)/8), (3, 9)/g" python/setup.py