summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormschubert2018-12-31 21:24:04 +0100
committermschubert2018-12-31 21:24:53 +0100
commitf1395172d3688df3f086ddb96cdce14c98d81d66 (patch)
tree63398077cc4b7aeab2c1f38ff459b40ccf9d6c4c
downloadaur-f1395172d3688df3f086ddb96cdce14c98d81d66.tar.gz
add python-rchitect (will replace python-rapi)
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77922258553d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-rchitect
+ pkgdesc = Minimal R API for Python
+ pkgver = 0.2.4
+ pkgrel = 1
+ url = https://github.com/randy3k/rapi
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = python-setuptools
+ depends = r>3.4.0
+ depends = python-multipledispatch
+ source = https://github.com/randy3k/rchitect/archive/v0.2.4.tar.gz
+ sha256sums = 122e81c69bf73411b8b1ee021684e0e56d944f1b857102e455831a13ff79f0c8
+
+pkgname = python-rchitect
+
+pkgname = python2-rchitect
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d95ffa9e7837
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Michael Schubert <mschu.dev at gmail>
+pkgname=(python-rchitect python2-rchitect)
+_pkgname=${pkgname#python-}
+pkgver=0.2.4
+pkgrel=1
+pkgdesc="Minimal R API for Python"
+url="https://github.com/randy3k/rapi"
+arch=('i686' 'x86_64')
+license=('MIT')
+depends=('r>3.4.0' 'python-multipledispatch')
+makedepends=('python-setuptools')
+#replaces=('python-rapi')
+source=("https://github.com/randy3k/rchitect/archive/v$pkgver.tar.gz")
+sha256sums=('122e81c69bf73411b8b1ee021684e0e56d944f1b857102e455831a13ff79f0c8')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package_python-rchitect() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --skip-build --prefix=/usr --root="$pkgdir" --optimize=1
+}
+
+package_python2-rchitect() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py install --skip-build --prefix=/usr --root="$pkgdir" --optimize=1
+}