summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Ortiz Manero2022-03-12 20:10:59 +0000
committerMario Ortiz Manero2022-03-12 20:10:59 +0000
commit8685c5047f722f4cdffff01655109ccfd5f7baec (patch)
treeb72d6d1588eefa066949f3393cd04376b3aff957
parent5178253384cfdcb37f274d75a50bf9293d6fb8dc (diff)
downloadaur-8685c5047f722f4cdffff01655109ccfd5f7baec.tar.gz
Fix env
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6b47e386898..1c76824b39b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-readchar
pkgdesc = Python library to read characters and key strokes
pkgver = 3.0.5
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/magmax/python-readchar
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 3156f8af1bda..a49eadf0e81c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Kyle Laker <kyle+aur@laker.email>
pkgname=python-readchar
pkgver=3.0.5
-pkgrel=5
+pkgrel=6
pkgdesc="Python library to read characters and key strokes"
arch=("any")
url="https://github.com/magmax/python-readchar"
@@ -26,12 +26,12 @@ prepare() {
build() {
cd "${srcdir}/$pkgname-$pkgver"
- python -m build --wheel --no-isolation
+ GITHUB_REF="refs/tags/$pkgver" python -m build --wheel --no-isolation
}
package() {
cd "${srcdir}/$pkgname-$pkgver"
- GITHUB_REF="refs/tags/$pkgver" python -m installer --destdir="$pkgdir" dist/*.whl
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}