summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikita Volodin [Никита Володин]2015-06-23 23:02:19 -0300
committerNikita Volodin [Никита Володин]2015-06-23 23:02:19 -0300
commite0be05368d1b2d4f18defee93253e099a0051feb (patch)
treed6ba547c4eb8308d6d2c7a146c509926789b7e07
downloadaur-e0be05368d1b2d4f18defee93253e099a0051feb.tar.gz
feat(python-readlike): initial import
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD23
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f7256295ede
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-readlike
+ pkgdesc = GNU Readline-like line editing module
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = http://jangler.info/code/readlike
+ arch = any
+ license = MIT
+ depends = python
+ source = https://pypi.python.org/packages/source/r/readlike/readlike-0.1.1.tar.gz
+ md5sums = 368292c5a247285774c356d6ece83894
+
+pkgname = python-readlike
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8e7aa272f6d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*~
+
+pkg/
+src/
+
+*.tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a5b8ebdccc5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: qlonik <volodin.n at gmail dot com>
+
+pkgname=python-readlike
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="GNU Readline-like line editing module"
+url="http://jangler.info/code/readlike"
+depends=('python')
+license=('MIT')
+arch=('any')
+source=("https://pypi.python.org/packages/source/r/readlike/readlike-$pkgver.tar.gz")
+md5sums=('368292c5a247285774c356d6ece83894')
+
+build() {
+ cd $srcdir/readlike-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/readlike-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}