summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjopejoe12022-09-14 23:13:18 +0200
committerjopejoe12022-09-14 23:13:18 +0200
commit235dd02a7c4a68d01d5dc6794a86248127a0fd2a (patch)
tree8d7077a08e7dc40922ab9614ccf570bf6f399db1
downloadaur-235dd02a7c4a68d01d5dc6794a86248127a0fd2a.tar.gz
Init commit
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD74
2 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c1b34c9859c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = python-realcugan-ncnn-vulkan-git
+ pkgdesc = A Python FFI of nihui/realcugan-ncnn-vulkan achieved with SWIG
+ pkgver = 1.0.2.r3.gf2a4301
+ pkgrel = 1
+ url = https://github.com/media2x/realcugan-ncnn-vulkan-python
+ arch = any
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ makedepends = python-cmake-build-extension
+ depends = python
+ depends = vulkan-headers
+ depends = vulkan-icd-loader
+ depends = swig
+ depends = python-pillow
+ provides = python-realcugan-ncnn-vulkan
+ conflicts = python-realcugan-ncnn-vulkan
+ source = git+https://github.com/media2x/realcugan-ncnn-vulkan-python.git
+ source = git+https://github.com/nihui/realcugan-ncnn-vulkan.git
+ source = git+https://github.com/Tencent/ncnn.git
+ source = git+https://github.com/webmproject/libwebp.git
+ source = git+https://github.com/pybind/pybind11.git
+ source = git+https://github.com/KhronosGroup/glslang.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = python-realcugan-ncnn-vulkan-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73ce1958a8e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,74 @@
+# Maintainer : jopejoe1 <johannes@joens.email>
+
+_pkgname=realcugan-ncnn-vulkan
+pkgname=python-$_pkgname-git
+pkgver=1.0.2.r3.gf2a4301
+pkgrel=1
+pkgdesc="A Python FFI of nihui/$_pkgname achieved with SWIG "
+url="https://github.com/media2x/$_pkgname-python"
+arch=("any")
+license=("MIT")
+depends=(
+ "python"
+ "vulkan-headers"
+ "vulkan-icd-loader"
+ "swig"
+ "python-pillow"
+)
+makedepends=(
+ "cmake"
+ "git"
+ "python-cmake-build-extension"
+)
+provides=('python-realcugan-ncnn-vulkan')
+conflicts=('python-realcugan-ncnn-vulkan')
+source=(
+ "git+https://github.com/media2x/$_pkgname-python.git"
+ "git+https://github.com/nihui/$_pkgname.git"
+ "git+https://github.com/Tencent/ncnn.git"
+ "git+https://github.com/webmproject/libwebp.git"
+ "git+https://github.com/pybind/pybind11.git"
+ "git+https://github.com/KhronosGroup/glslang.git"
+)
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+)
+
+pkgver() {
+ cd $_pkgname-python
+ echo $(git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g')
+}
+
+prepare() {
+ cd $_pkgname-python
+ git submodule init
+ git config submodule.realcugan_ncnn_vulkan_python/$_pkgname.url "$srcdir/$_pkgname"
+ git submodule update
+
+ cd realcugan_ncnn_vulkan_python/$_pkgname
+ git submodule init
+ git config submodule.src/ncnn.url "$srcdir/ncnn"
+ git config submodule.src/libwebp.url "$srcdir/libwebp"
+ git submodule update
+
+ cd src/ncnn
+ git submodule init
+ git config submodule.glslang.url "$srcdir/glslang"
+ git config submodule.python/pybind11.url "$srcdir/pybind11"
+ git submodule update
+}
+
+build() {
+ cd $_pkgname-python
+ python setup.py build
+}
+
+package() {
+ cd $_pkgname-python
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}