summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Wojdyła2022-09-08 17:15:16 +0200
committerMichał Wojdyła2022-09-08 17:15:16 +0200
commit1c0bfab62896dff3772fb601626330c15236c958 (patch)
treeed4ff208a18f0e153307dd30d4a9af90bf2433f9
parent70410c8a459748a859b22ceb4c3ed4e1499df365 (diff)
downloadaur-1c0bfab62896dff3772fb601626330c15236c958.tar.gz
fix tests with pytest-asyncio 0.19
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc61ef97f367..4a66145b9279 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-red-lavalink
pkgdesc = Lavalink client library used in Red-DiscordBot
pkgver = 0.11.0rc0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Cog-Creators/Red-Lavalink
arch = any
license = GPL3
@@ -10,6 +10,8 @@ pkgbase = python-red-lavalink
depends = python-discord
depends = python-red-commons
source = Red-Lavalink-0.11.0rc0.tar.gz::https://github.com/Cog-Creators/Red-Lavalink/archive/0.11.0rc0.tar.gz
+ source = https://github.com/Cog-Creators/Red-Lavalink/commit/93d76d490ac0bb2883e6ff717e4eb09a4a729d01.patch
sha256sums = 59116b7b260472c76e6d40542a2c85fc099857de280954f52b69e7b9a51eba40
+ sha256sums = 7d521be8da6e89835d6838db367a11582c2a3b09754b9371b5b2b218c7afbaa7
pkgname = python-red-lavalink
diff --git a/PKGBUILD b/PKGBUILD
index 67085c3e67ba..304e80493da9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=Red-Lavalink
pkgname=python-red-lavalink
pkgver=0.11.0rc0
-pkgrel=1
+pkgrel=2
pkgdesc="Lavalink client library used in Red-DiscordBot"
arch=(any)
url="https://github.com/Cog-Creators/Red-Lavalink"
@@ -11,9 +11,13 @@ license=('GPL3')
depends=('python-discord' 'python-red-commons')
makedepends=('python-setuptools')
checkdepends=('python-pytest-asyncio')
-source=("$_pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('59116b7b260472c76e6d40542a2c85fc099857de280954f52b69e7b9a51eba40')
+source=("$_pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz" "https://github.com/Cog-Creators/Red-Lavalink/commit/93d76d490ac0bb2883e6ff717e4eb09a4a729d01.patch")
+sha256sums=('59116b7b260472c76e6d40542a2c85fc099857de280954f52b69e7b9a51eba40' '7d521be8da6e89835d6838db367a11582c2a3b09754b9371b5b2b218c7afbaa7')
+prepare() {
+ cd "$_pkgname-$pkgver"
+ patch -Np1 -i ../93d76d490ac0bb2883e6ff717e4eb09a4a729d01.patch
+}
build() {
cd "$_pkgname-$pkgver"
python setup.py build