summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRiccardo Berto2019-02-07 22:55:59 +0100
committerRiccardo Berto2019-02-07 22:55:59 +0100
commitc550bf2df0b0ea20b47cf87c7f2c17c5b4f0f22e (patch)
treee929ebc4017798508c370c5e01a9881f2b96a60a
downloadaur-c550bf2df0b0ea20b47cf87c7f2c17c5b4f0f22e.tar.gz
First commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d453e457f262
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-redisgraph
+ pkgdesc = RedisGraph Python Client
+ pkgver = 1.7
+ pkgrel = 1
+ url = https://github.com/redislabs/redisgraph-py
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/r/redisgraph/redisgraph-1.7.tar.gz
+ md5sums = 6de7ea87415911d5cc6bce8279f09f39
+
+pkgname = python-redisgraph
+ depends = python
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c2a0de7ec43
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgbase=('python-redisgraph')
+pkgname=('python-redisgraph')
+_module='redisgraph'
+pkgver='1.7'
+pkgrel=1
+pkgdesc="RedisGraph Python Client"
+url="https://github.com/redislabs/redisgraph-py"
+depends=('python')
+makedepends=('python-setuptools')
+license=('BSD')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/r/redisgraph/redisgraph-${pkgver}.tar.gz")
+md5sums=('6de7ea87415911d5cc6bce8279f09f39')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}