summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2018-09-09 15:54:40 +0800
committerUniversebenzene2018-09-09 15:54:40 +0800
commitae1560610b7ad3baecca590c98c78e750089dec6 (patch)
treef7dcf113c085608ab72086f168b8d2d01e3da860
parent14b5a1b24cf05419c4a5d503b962b3f99d1fd806 (diff)
downloadaur-ae1560610b7ad3baecca590c98c78e750089dec6.tar.gz
Update to version 0.3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 19 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93a91a00a997..6e572a2163a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,23 @@
# Generated by mksrcinfo v8
-# Sun Feb 18 16:34:09 UTC 2018
+# Sun Sep 9 07:53:25 UTC 2018
pkgbase = python-regions
pkgdesc = Astropy affilated package for region handling
- pkgver = 0.2
- pkgrel = 3
+ pkgver = 0.3
+ pkgrel = 1
url = http://astropy-regions.readthedocs.io/en/latest/
arch = i686
arch = x86_64
license = BSD
+ checkdepends = python-pytest-astropy
+ checkdepends = python-astropy-healpix
makedepends = cython
makedepends = python-astropy>=1.2
makedepends = python-astropy-helpers
makedepends = python-sphinx
makedepends = python-matplotlib
- source = https://files.pythonhosted.org/packages/source/r/regions/regions-0.2.tar.gz
- md5sums = 48597dc17906e478292040dae2df5596
+ makedepends = python-shapely
+ source = https://files.pythonhosted.org/packages/source/r/regions/regions-0.3.tar.gz
+ md5sums = b2f0b08cdaa2b40519de665f9af2a25a
pkgname = python-regions
depends = python>=3.4
@@ -22,7 +25,6 @@ pkgname = python-regions
depends = python-astropy>=1.2
optdepends = python-matplotlib>=1.5: Plotting support
optdepends = python-shapely: Managing geometric objects
- optdepends = python-pytest-arraydiff: For testing
optdepends = python-regions-doc: Documentation for AstroPy Regions
pkgname = python-regions-doc
diff --git a/PKGBUILD b/PKGBUILD
index 50a93d35ce6f..5e0811156cdf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgbase=python-regions
pkgname=('python-regions' 'python-regions-doc')
-pkgver=0.2
-pkgrel=3
+pkgver=0.3
+pkgrel=1
pkgdesc="Astropy affilated package for region handling"
arch=('i686' 'x86_64')
url="http://astropy-regions.readthedocs.io/en/latest/"
license=('BSD')
-makedepends=('cython' 'python-astropy>=1.2' 'python-astropy-helpers' 'python-sphinx' 'python-matplotlib')
-#checkdepends=('python-pytest-arraydiff')
+makedepends=('cython' 'python-astropy>=1.2' 'python-astropy-helpers' 'python-sphinx' 'python-matplotlib' 'python-shapely')
+checkdepends=('python-pytest-astropy' 'python-astropy-healpix')
source=("https://files.pythonhosted.org/packages/source/r/regions/regions-${pkgver}.tar.gz")
-md5sums=('48597dc17906e478292040dae2df5596')
+md5sums=('b2f0b08cdaa2b40519de665f9af2a25a')
prepare() {
cd ${srcdir}/regions-${pkgver}
@@ -26,17 +26,16 @@ build () {
python setup.py build_docs
}
-#check(){
-# cd ${srcdir}/astroplan-${pkgver}
-#
-# python setup.py test
-#}
+check(){
+ cd ${srcdir}/regions-${pkgver}
+
+ python setup.py test
+}
package_python-regions() {
depends=('python>=3.4' 'python-numpy>=1.9' 'python-astropy>=1.2')
optdepends=('python-matplotlib>=1.5: Plotting support'
'python-shapely: Managing geometric objects'
- 'python-pytest-arraydiff: For testing'
'python-regions-doc: Documentation for AstroPy Regions')
cd ${srcdir}/regions-${pkgver}
@@ -45,7 +44,7 @@ package_python-regions() {
package_python-regions-doc() {
pkgdesc="Documentation for AstroPy Regions"
- cd ${srcdir}/regions-${pkgver}/docs/_build
+ cd ${srcdir}/regions-${pkgver}/build/sphinx
install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"