summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2021-10-05 10:07:33 +0800
committerUniversebenzene2021-10-05 10:07:33 +0800
commitc58a8a36188e0ec04bb835ada3d3f8a8560e776c (patch)
tree1d7cf092f04d34ede1b5c810454b6f7cf5b15f52
parentba95f32801ad4a8ae7b78fbda73568020866a3ff (diff)
downloadaur-c58a8a36188e0ec04bb835ada3d3f8a8560e776c.tar.gz
Correct pyver definition for 3.10
-rw-r--r--.SRCINFO1
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD2
3 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7344f504dae3..2bd870ebedca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -19,4 +19,3 @@ pkgname = python-relic
pkgname = python2-relic
depends = python2
-
diff --git a/.gitignore b/.gitignore
index 0d6e3b36c63a..06a3cebf3615 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,5 +4,6 @@ pkg
*.tar.gz
*.tar.bz2
*.part
-*.pkg.tar.xz
+*.pkg.tar*
*.log
+LICENSE*
diff --git a/PKGBUILD b/PKGBUILD
index 1a2078f3b5e9..34ef4f7767b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,10 +12,10 @@ makedepends=('python-setuptools' 'python2-setuptools')
checkdepends=('python-pytest' 'python2-pytest' 'git')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
md5sums=('5f8124328c523f01a27e3883ee8b5d84')
-_pyver=$(python -V | cut -c 8-10)
prepare() {
cp -a ${srcdir}/${_pyname}-${pkgver}{,-py2}
+ export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
}
build() {