summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2024-03-08 04:18:00 +0800
committerlilac2024-03-08 04:18:00 +0800
commitb0c4bfc11aea59871301c9633f572ca2c0329dd4 (patch)
tree247e491fe1affb5d1bd87682071ee09e8dbcd686
parentcdc3ba14e6537d60cdb7f707fa39c34773a15c95 (diff)
downloadaur-b0c4bfc11aea59871301c9633f572ca2c0329dd4.tar.gz
[lilac] updated to 2022.7.27-3
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70b3798854e9..abdd9d998706 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = python-remi
pkgdesc = Cross-platform GUI library which renders in a web browser
pkgver = 2022.7.27
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/dddomodossola/remi
arch = any
- license = Apache
+ license = Apache-2.0
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python
optdepends = python-pywebview: for standalone app
source = python-remi-2022.7.27.tar.gz::https://github.com/dddomodossola/remi/archive/refs/tags/2022.7.27.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 5d91e3d3b866..dd65fe84c38f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,19 @@
_pkgname=remi
pkgname=python-remi
pkgver=2022.7.27
-pkgrel=2
+pkgrel=3
pkgdesc='Cross-platform GUI library which renders in a web browser'
arch=('any')
url='https://github.com/dddomodossola/remi'
-license=('Apache')
+license=('Apache-2.0')
depends=(
python
)
makedepends=(
+ python-build
+ python-installer
python-setuptools
+ python-wheel
)
optdepends=(
'python-pywebview: for standalone app'
@@ -22,13 +25,13 @@ sha256sums=('362375d60e4e460a88c9f2198a83ae7a6476a32987d2fc97154211be829331f5')
build() {
cd "${_pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
cd "${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="${pkgdir}" dist/*.whl
rm -rf "${pkgdir}${site_packages}/test"
install -dm755 "${pkgdir}/usr/share/doc/${pkgname}"
mv -vf "examples" "${pkgdir}/usr/share/doc/${pkgname}"