aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYngve Levinsen2020-01-03 08:22:38 +0100
committerYngve Levinsen2020-01-03 08:22:38 +0100
commit368c16e64c26f7289038d8e3dd7966fd39caacb2 (patch)
treeb1a0421b6be4806de801fb49a9e2b28ce5893c32
parente709dcbb41c5fd072cdcc740b59b76e287e5d079 (diff)
downloadaur-368c16e64c26f7289038d8e3dd7966fd39caacb2.tar.gz
Updated
- removed folders tests and editor (too generic, may cause conflicts)
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
-rw-r--r--README.md17
3 files changed, 26 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a7c2a285ea0..c701743ec484 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = python-remi-git
pkgdesc = Cross-platform GUI library which renders in a web browser.
- pkgver = 0.1.1.r245.g7b7fb36
+ pkgver = 2019.11.r73.g009357e
pkgrel = 1
url = https://github.com/dddomodossola/remi/
arch = any
license = Apache
+ makedepends = git
depends = python
options = !emptydirs
source = git+https://github.com/dddomodossola/remi.git
diff --git a/PKGBUILD b/PKGBUILD
index 646d4f945479..e39d691415e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: Blair Bonnett <blair.bonnett@gmail.com>
pkgname=python-remi-git
-pkgver=0.1.1.r245.g7b7fb36
+pkgver=2019.11.r73.g009357e
pkgrel=1
pkgdesc="Cross-platform GUI library which renders in a web browser."
arch=('any')
url="https://github.com/dddomodossola/remi/"
license=("Apache")
depends=("python")
+makedepends=("git")
options=(!emptydirs)
source=('git+https://github.com/dddomodossola/remi.git')
sha256sums=('SKIP')
@@ -20,8 +21,11 @@ pkgver() {
package() {
cd "$srcdir/remi"
python setup.py install --root="$pkgdir/" --optimize=1
- mkdir -p "$pkgdir/usr/share/doc/python-remi-git"
- cp -r "$srcdir/remi/examples" "$pkgdir/usr/share/doc/python-remi-git"
+ cd "$pkgdir"
+ rm -r usr/lib/python3.[1-9]/site-packages/test/
+ rm -r usr/lib/python3.[1-9]/site-packages/editor/
+ mkdir -p "usr/share/doc/python-remi-git"
+ cp -r "$srcdir/remi/examples" "usr/share/doc/python-remi-git"
}
# vim:set ts=2 sw=2 et:
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..ce46e701027a
--- /dev/null
+++ b/README.md
@@ -0,0 +1,17 @@
+
+
+## Build
+
+```bash
+# Test PKGBUILD
+namcap PKGBUILD
+# Build
+makepkg
+# Test artifact
+namcap <package file name>.pkg.tar.xz
+# Install
+pacman -U <package file name>.pkg.tar.xz
+# Generate SRCINFO
+makepkg --printsrcinfo > .SRCINFO
+# Commit & Publish
+```