aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlair Bonnett2015-12-03 13:04:22 +1300
committerBlair Bonnett2015-12-03 13:04:22 +1300
commite709dcbb41c5fd072cdcc740b59b76e287e5d079 (patch)
treea453e223092529afb51dfb2817118087789cbdc4
downloadaur-e709dcbb41c5fd072cdcc740b59b76e287e5d079.tar.gz
Initial upload to AUR.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a7c2a285ea0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-remi-git
+ pkgdesc = Cross-platform GUI library which renders in a web browser.
+ pkgver = 0.1.1.r245.g7b7fb36
+ pkgrel = 1
+ url = https://github.com/dddomodossola/remi/
+ arch = any
+ license = Apache
+ depends = python
+ options = !emptydirs
+ source = git+https://github.com/dddomodossola/remi.git
+ sha256sums = SKIP
+
+pkgname = python-remi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..646d4f945479
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Blair Bonnett <blair.bonnett@gmail.com>
+
+pkgname=python-remi-git
+pkgver=0.1.1.r245.g7b7fb36
+pkgrel=1
+pkgdesc="Cross-platform GUI library which renders in a web browser."
+arch=('any')
+url="https://github.com/dddomodossola/remi/"
+license=("Apache")
+depends=("python")
+options=(!emptydirs)
+source=('git+https://github.com/dddomodossola/remi.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/remi"
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+package() {
+ cd "$srcdir/remi"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ mkdir -p "$pkgdir/usr/share/doc/python-remi-git"
+ cp -r "$srcdir/remi/examples" "$pkgdir/usr/share/doc/python-remi-git"
+}
+
+# vim:set ts=2 sw=2 et: