summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHLFH2024-04-08 16:27:36 +0200
committerHLFH2024-04-08 16:27:36 +0200
commit206750b0c0a1d5129ac36fbd269845e28a03336c (patch)
treeb135c302445af24e3333dc3d5e710f916466edf0
downloadaur-206750b0c0a1d5129ac36fbd269845e28a03336c.tar.gz
initial release
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore2
-rw-r--r--.nvchecker.toml3
-rw-r--r--PKGBUILD33
4 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a0adad2003a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-reportlab3
+ pkgdesc = A proven industry-strength PDF generating solution
+ pkgver = 3.6.12
+ pkgrel = 1
+ url = https://www.reportlab.com/
+ arch = x86_64
+ license = BSD
+ makedepends = freetype2
+ makedepends = python-pillow
+ makedepends = mercurial
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ depends = python
+ depends = freetype2
+ depends = python-pillow
+ source = https://files.pythonhosted.org/packages/source/r/reportlab/reportlab-3.6.12.tar.gz
+ b2sums = 106e0ede2b3c039152ae5a39e0aa5b3bf0239789ba08630f751260b75305973bff13730e3f7419340514a4f0174223dddf522cd9408b8dd04fbe39b84979b152
+
+pkgname = python-reportlab3
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..60e986fe835e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.tar.gz
+*pkg.tar.zst
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..64163a77c819
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,3 @@
+[python-reportlab]
+source = "pypi"
+pypi = "reportlab"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bbf6bd369e1b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: HLFH <gaspard@dhautefeuille.eu>
+
+_origname=reportlab
+pkgname=python-reportlab3
+pkgver=3.6.12
+pkgrel=1
+pkgdesc="A proven industry-strength PDF generating solution"
+arch=('x86_64')
+url="https://www.reportlab.com/"
+depends=('python' 'freetype2' 'python-pillow')
+makedepends=('freetype2' 'python-pillow' 'mercurial' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+license=('BSD')
+source=(https://files.pythonhosted.org/packages/source/${_origname::1}/${_origname}/${_origname}-${pkgver}.tar.gz)
+b2sums=('106e0ede2b3c039152ae5a39e0aa5b3bf0239789ba08630f751260b75305973bff13730e3f7419340514a4f0174223dddf522cd9408b8dd04fbe39b84979b152')
+
+build() {
+ cd ${_origname}-${pkgver}
+ python setup.py build
+ python -m build --wheel --no-isolation
+}
+
+check() {
+ cd ${_origname}-${pkgver}
+ export PYTHONPATH="build:$PYTHONPATH"
+ python -m unittest discover -vs tests || true
+ rm tests/_i_am_actually_a_*
+}
+
+package() {
+ cd ${_origname}-${pkgver}
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -D -m644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/license.txt
+}