summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2023-05-20 14:47:07 +0800
committerUniversebenzene2023-05-20 14:47:07 +0800
commit45fbff80895b53d0723a1c7b5c49376e56babe65 (patch)
tree338aae614832223f6f7e95ac1822228162e0c94b
parent2278659ed0021e1d1e8a901b4bbd9fc9ce6948a4 (diff)
downloadaur-45fbff80895b53d0723a1c7b5c49376e56babe65.tar.gz
Update to version 0.11.0
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD21
2 files changed, 27 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d64c0f8b114e..2f5656da95f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-reproject
pkgdesc = Python-based Astronomical image reprojection
- pkgver = 0.10.0
+ pkgver = 0.11.0
pkgrel = 1
url = http://reproject.readthedocs.io
arch = i686
@@ -9,10 +9,12 @@ pkgbase = python-reproject
checkdepends = python-pytest-arraydiff
checkdepends = python-pytest-astropy-header
checkdepends = python-pytest-doctestplus
+ checkdepends = python-pytest-remotedata
checkdepends = python-matplotlib
checkdepends = python-sunpy
checkdepends = python-gwcs
checkdepends = python-shapely
+ checkdepends = python-zarr
makedepends = cython>=0.29.32
makedepends = python-setuptools-scm
makedepends = python-extension-helpers
@@ -21,17 +23,22 @@ pkgbase = python-reproject
makedepends = python-installer
makedepends = python-sphinx-astropy
makedepends = python-astropy-healpix
+ makedepends = python-dask
makedepends = python-scipy
makedepends = python-pyvo
- source = https://files.pythonhosted.org/packages/source/r/reproject/reproject-0.10.0.tar.gz
- md5sums = 97919e12687f55063c1fd47c9be9e965
+ source = https://files.pythonhosted.org/packages/source/r/reproject/reproject-0.11.0.tar.gz
+ md5sums = d0714c4f05dfe6bad7ea61c925888df6
pkgname = python-reproject
depends = python>=3.8
- depends = python-numpy>=1.17
- depends = python-scipy>=1.3
- depends = python-astropy>=4.0
+ depends = python-numpy>=1.20
+ depends = python-cloudpickle
+ depends = python-dask>=2020
+ depends = python-fsspec
+ depends = python-scipy>=1.5
+ depends = python-astropy>=5.0
depends = python-astropy-healpix>=0.6
+ depends = python-zarr
optdepends = python-shapely>=1.6: For some of the mosaicking functionality
optdepends = python-reproject-doc: Documentation for Reproject
optdepends = python-pytest-astropy: For testing
diff --git a/PKGBUILD b/PKGBUILD
index efe09331d033..e5b6dff20308 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=python-reproject
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=0.10.0
+pkgver=0.11.0
pkgrel=1
pkgdesc="Python-based Astronomical image reprojection"
arch=('i686' 'x86_64')
@@ -17,18 +17,21 @@ makedepends=('cython>=0.29.32'
'python-installer'
'python-sphinx-astropy'
'python-astropy-healpix'
+ 'python-dask'
'python-scipy'
'python-pyvo')
# 'python-mimeparse') # numpy for package itself
checkdepends=('python-pytest-arraydiff'
'python-pytest-astropy-header'
'python-pytest-doctestplus'
+ 'python-pytest-remotedata'
'python-matplotlib'
'python-sunpy'
'python-gwcs'
- 'python-shapely') # astropy-healpix scipy already in makedep
+ 'python-shapely'
+ 'python-zarr') # astropy-healpix dask scipy already in makedep
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('97919e12687f55063c1fd47c9be9e965')
+md5sums=('d0714c4f05dfe6bad7ea61c925888df6')
get_pyver() {
python -c "import sys; print('$1'.join(map(str, sys.version_info[:2])))"
@@ -58,10 +61,14 @@ check() {
package_python-reproject() {
depends=('python>=3.8'
- 'python-numpy>=1.17'
- 'python-scipy>=1.3'
- 'python-astropy>=4.0'
- 'python-astropy-healpix>=0.6')
+ 'python-numpy>=1.20'
+ 'python-cloudpickle'
+ 'python-dask>=2020'
+ 'python-fsspec'
+ 'python-scipy>=1.5'
+ 'python-astropy>=5.0'
+ 'python-astropy-healpix>=0.6'
+ 'python-zarr')
optdepends=('python-shapely>=1.6: For some of the mosaicking functionality'
'python-reproject-doc: Documentation for Reproject'
'python-pytest-astropy: For testing')