summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2019-04-11 11:19:23 -0400
committerBuildTools2019-04-11 11:19:23 -0400
commitcb0134c952935829b03f304fe72e36a1d73f140c (patch)
tree245650ae225f9c627d4915c8b8445f6a52aa9c62
downloadaur-cb0134c952935829b03f304fe72e36a1d73f140c.tar.gz
initial version
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD39
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff96da0998f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-req
+ pkgdesc = Simple python module for loading and dumping structures in req format.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/absperf/python-req
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ options = !emptydirs
+ source = https://github.com/absperf/python-req/archive/de878f08f4fb28fa140c80d5cbdb04518ef5e968.tar.gz
+ sha256sums = 67d0bf4c210aa5028cb1de5f83dd5825bc0475617870afa599ad67ff2873b289
+
+pkgname = python-req
+ pkgdesc = Simple python module for loading and dumping structures in req format. (python3 version)
+ depends = python
+
+pkgname = python2-req
+ pkgdesc = Simple python module for loading and dumping structures in req format. (python2 version)
+ depends = python2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05cd020fbc58
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Nikola Milinković <nikmil@gmail.com>
+# Submitter: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+
+pkgbase=python-req
+pkgname=('python-req' 'python2-req')
+pkgname=python-req
+pkgver=1.0.0
+_pkgcommit=de878f08f4fb28fa140c80d5cbdb04518ef5e968
+pkgrel=1
+pkgdesc="Simple python module for loading and dumping structures in req format."
+arch=(any)
+url="https://github.com/absperf/python-req"
+license=('MIT')
+makedepends=('python-setuptools' 'python2-setuptools')
+options=(!emptydirs)
+source=("https://github.com/absperf/python-req/archive/${_pkgcommit}.tar.gz")
+sha256sums=('67d0bf4c210aa5028cb1de5f83dd5825bc0475617870afa599ad67ff2873b289')
+
+package_python2-req() {
+ depends=('python2')
+ pkgdesc="Simple python module for loading and dumping structures in req format. (python2 version)"
+
+ cd "${srcdir}/${pkgbase}-${_pkgcommit}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+
+ install -v -m755 -d "${pkgdir}/usr/share/doc/${pkgname}"
+ install -v -m644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/"
+}
+
+package_python-req() {
+ depends=('python')
+ pkgdesc="Simple python module for loading and dumping structures in req format. (python3 version)"
+
+ cd "${srcdir}/${pkgbase}-${_pkgcommit}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+
+ install -v -m755 -d "${pkgdir}/usr/share/doc/${pkgname}"
+ install -v -m644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/"
+}