summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Rebischke2016-11-13 22:05:25 +0100
committerChristian Rebischke2016-11-13 22:05:25 +0100
commit2afcaacf65cc50719e4e79d6e4e08a588345a8b6 (patch)
tree022dc5daed3309b1dc2c1d3cdb5f61fc3b6727a1
parent3436e03a3ffc6c1f9322b67867a896fcc20e292f (diff)
downloadaur-2afcaacf65cc50719e4e79d6e4e08a588345a8b6.tar.gz
made src unique
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 267504521b55..2d90a35cba0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
-# Generated by mksrcinfo v8
-# Thu Feb 11 22:09:38 UTC 2016
pkgbase = python-requests-cache
pkgdesc = Persistent cache for requests library
- pkgver = 0.4.10
+ pkgver = 0.4.12
pkgrel = 1
url = https://github.com/reclosedev/requests-cache
arch = any
license = BSD
makedepends = python
makedepends = python2
- source = https://github.com/reclosedev/requests-cache/archive/v0.4.10.tar.gz
- sha512sums = 677923baf822a518958ff499197c668d43e15c300a4a86bf84d4a2bb9ddd97bfdd97ac0f9d064900fb5119a8fe43b129b6a29eaaba131beb5b031578799b94cc
+ source = requests-cache-0.4.12.tar.gz::https://github.com/reclosedev/requests-cache/archive/v0.4.12.tar.gz
+ sha512sums = 06d563d59c24f311209b81beb96130b75d1e849e0bb94ad636b3ac269eed7c89fdddfed8da86560473c4463425ea98953d30fb3da05efd614907855f130587fc
pkgname = python-requests-cache
depends = python
diff --git a/PKGBUILD b/PKGBUILD
index 340f89af6bf6..a7d065ae7117 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,18 +5,18 @@ _pyname=requests-cache
pkgname=('python-requests-cache' 'python2-requests-cache')
makedepends=('python' 'python2')
pkgver=0.4.12
-pkgrel=1
+pkgrel=2
pkgdesc="Persistent cache for requests library"
arch=('any')
url="https://github.com/reclosedev/requests-cache"
license=('BSD')
-source=("https://github.com/reclosedev/${_pyname}/archive/v${pkgver}.tar.gz")
+source=("${_pyname}-${pkgver}.tar.gz::https://github.com/reclosedev/${_pyname}/archive/v${pkgver}.tar.gz")
sha512sums=('06d563d59c24f311209b81beb96130b75d1e849e0bb94ad636b3ac269eed7c89fdddfed8da86560473c4463425ea98953d30fb3da05efd614907855f130587fc')
package_python-requests-cache() {
depends=('python')
cd "${srcdir}/${_pyname}-${pkgver}"
- python setup.py install -O1 --root=${pkgdir}
+ python setup.py install -O1 --root="${pkgdir}"
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm 644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README"
@@ -25,7 +25,7 @@ package_python-requests-cache() {
package_python2-requests-cache() {
depends=('python2')
cd "${srcdir}/${_pyname}-${pkgver}"
- python2 setup.py install -O1 --root=${pkgdir}
+ python2 setup.py install -O1 --root="${pkgdir}"
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm 644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README"