summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2022-09-16 17:10:46 +0200
committerPhilipp A2022-09-16 17:10:46 +0200
commit3ba728795a73814589ffa1adc4f0baf756be0c6f (patch)
treed8901e8054bded442c04420843f41ba9fa1a437c
parent4a667528e977db133bc9e8e4015fce4cb3c9d27e (diff)
downloadaur-3ba728795a73814589ffa1adc4f0baf756be0c6f.tar.gz
makedeps
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af4cd05fbf8f..2850f630b04b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-requests-cache
pkgdesc = A transparent persistent cache for the requests library
pkgver = 0.9.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/reclosedev/requests-cache
arch = any
license = custom:BSD-2-clause
@@ -11,9 +11,10 @@ pkgbase = python-requests-cache
checkdepends = python-itsdangerous
checkdepends = python-ujson
checkdepends = python-timeout-decorator
+ makedepends = python-poetry-core
makedepends = python-build
makedepends = python-installer
- makedepends = python-poetry-core
+ makedepends = python-wheel
depends = python-requests
depends = python-appdirs
depends = python-cattrs
diff --git a/PKGBUILD b/PKGBUILD
index 3b5497f07e72..b3a3d15f3471 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,20 +9,22 @@ _base=requests-cache
pkgname=python-${_base}
pkgdesc="A transparent persistent cache for the requests library"
pkgver=0.9.6
-pkgrel=1
+pkgrel=2
arch=(any)
url="https://github.com/reclosedev/${_base}"
license=('custom:BSD-2-clause')
depends=(python-requests python-appdirs python-cattrs python-url-normalize)
-makedepends=(python-build python-installer python-poetry-core)
-optdepends=('python-boto3: Cache backend for Amazon DynamoDB database'
+makedepends=(python-poetry-core python-build python-installer python-wheel)
+optdepends=(
+ 'python-boto3: Cache backend for Amazon DynamoDB database'
'python-botocore: Interface for Amazon Web Services'
'python-pymongo: Cache backend for MongoDB database'
'python-redis: Cache backend for Redis cache'
'python-bson: for BSON codec'
'python-itsdangerous: for pass trusted data to untrusted environments'
'python-yaml: for bindings yaml support'
- 'python-ujson: for JSON serializer for improved performance')
+ 'python-ujson: for JSON serializer for improved performance'
+)
checkdepends=(python-pytest python-requests-mock python-responses python-itsdangerous python-ujson python-timeout-decorator)
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
sha512sums=('88e4745bed278224ccd1eb815a4f9da84051bab79c43122fa97899c3a8ad87ad7bfd929f87680eb6f73b1ff14267d2519afd9ef8815f10597769cab8ada7f8b5')