summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2021-10-20 14:43:25 -0500
committerCarlos Aznarán Laos2021-10-20 14:43:25 -0500
commit45f5bb82c266389b8a93bfe7b2450dd1f6db7f70 (patch)
tree25514f5db1aef4d1825efbb0293e60755c40faf8
parentdc5b1e7ac06177307c73d195dd2a3abc254c61d2 (diff)
downloadaur-45f5bb82c266389b8a93bfe7b2450dd1f6db7f70.tar.gz
Remove duplicate source array, add suggest from user to fix installation in build()
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD29
2 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 77774a10abd4..f1a0899821a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-requests-cache
pkgdesc = Transparent persistent cache for http://python-requests.org library
pkgver = 0.8.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/reclosedev/requests-cache
arch = any
license = custom:BSD-2-clause
@@ -21,7 +21,7 @@ pkgbase = python-requests-cache
optdepends = python-boto3: Cache backend for Amazon DynamoDB database
optdepends = python-redis: Cache backend for Redis cache
optdepends = python-pymongo: Cache backend for MongoDB database
- source = https://github.com/reclosedev/requests-cache/archive/v0.8.1.tar.gz
+ source = requests-cache-0.8.1.tar.gz::https://github.com/reclosedev/requests-cache/archive/v0.8.1.tar.gz
sha512sums = 245ee7059afab50f32af9c8831fe11c14d5bd53fe6bbf02e5844974e0e5ea6c33e005f234485f245ee418ae03277c6e2cc41046a385ff138e58785cf37b119ea
pkgname = python-requests-cache
diff --git a/PKGBUILD b/PKGBUILD
index d4e375ba664b..89ad6e0f33b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Maintainer: Jordan Cook <JCook83@gmail.com>
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Benoit Pierre <benoit.pierre@gmail.com>
# Contributor: Simon Legner <Simon.Legner@gmail.com>
# Contributor: Aniket Pradhan <aniket17133[at]iiitd[dot]ac[dot]in>
# Contributor: Roman Haritonov <reclosedev[at]gmail[dot]com>
@@ -7,33 +8,35 @@ _base=requests-cache
pkgname=python-${_base}
pkgdesc="Transparent persistent cache for http://python-requests.org library"
pkgver=0.8.1
-pkgrel=1
+pkgrel=2
arch=('any')
url="https://github.com/reclosedev/${_base}"
license=('custom:BSD-2-clause')
depends=(python-requests python-url-normalize python-cattrs python-appdirs)
makedepends=(python-build python-install python-poetry)
optdepends=('python-boto3: Cache backend for Amazon DynamoDB database'
- 'python-redis: Cache backend for Redis cache'
- 'python-pymongo: Cache backend for MongoDB database')
-source=("https://files.pythonhosted.org/packages/source/r/$_pkgname/$_pkgname-$pkgver.tar.gz")
+ 'python-redis: Cache backend for Redis cache'
+ 'python-pymongo: Cache backend for MongoDB database')
checkdepends=(python-pytest python-requests-mock python-responses python-itsdangerous python-ujson python-timeout-decorator)
-source=(${url}/archive/v${pkgver}.tar.gz)
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
sha512sums=('245ee7059afab50f32af9c8831fe11c14d5bd53fe6bbf02e5844974e0e5ea6c33e005f234485f245ee418ae03277c6e2cc41046a385ff138e58785cf37b119ea')
build() {
- cd "${_base}-${pkgver}"
- python -m build --wheel --skip-dependency-check --no-isolation
+ cd "${_base}-${pkgver}"
+ # Note: set `GIT_CEILING_DIRECTORIES` to prevent poetry
+ # from incorrectly using a parent git checkout info.
+ # https://github.com/pypa/build/issues/384#issuecomment-947675975
+ GIT_CEILING_DIRECTORIES="${PWD}/.." python -m build --wheel --skip-dependency-check --no-isolation
}
check() {
- cd "${_base}-${pkgver}"
- python -m pytest --ignore=tests/integration
+ cd "${_base}-${pkgver}"
+ python -m pytest --ignore=tests/integration
}
package() {
- cd "${_base}-${pkgver}"
- export PYTHONHASHSEED=0
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m install --optimize=1 --destdir="${pkgdir}" dist/*.whl
- install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ cd "${_base}-${pkgver}"
+ export PYTHONHASHSEED=0
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m install --optimize=1 --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}