summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2021-08-11 12:12:25 +0200
committerPhilipp A2021-08-11 12:12:25 +0200
commit7c905cffc1ca92d6f53e10525df266c9c62681b1 (patch)
treedd8c35535d952e5a5da4dc8c83ffbaf6458b26ba
parent0be4cd529e6942db9d0044ca4e0fbe74273ed3f4 (diff)
downloadaur-7c905cffc1ca92d6f53e10525df266c9c62681b1.tar.gz
deps
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af0ba853a23f..fdb48567945d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = python-requests-cache
pkgdesc = Transparent persistent cache for http://python-requests.org/ library.
pkgver = 0.7.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/reclosedev/requests-cache
arch = x86_64
license = BSD
- makedepends = git
makedepends = python-setuptools
depends = python
depends = python-requests
+ depends = python-url-normalize
+ depends = python-itsdangerous
+ depends = python-attrs
conflicts = python2-requests-cache
source = https://files.pythonhosted.org/packages/source/r/requests-cache/requests-cache-0.7.3.tar.gz
sha256sums = d17c95b0fa52670044356378886dbaf8e25069123d4fced43e05cd13b38c42f8
diff --git a/PKGBUILD b/PKGBUILD
index 266784aa4764..747672723197 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,13 +6,13 @@
_pkgname=requests-cache
pkgname=python-requests-cache
pkgver=0.7.3
-pkgrel=1
+pkgrel=2
pkgdesc='Transparent persistent cache for http://python-requests.org/ library.'
arch=(x86_64)
url="https://github.com/reclosedev/$_pkgname"
license=(BSD)
-depends=(python python-requests)
-makedepends=(git python-setuptools)
+depends=(python python-requests python-url-normalize python-itsdangerous python-attrs)
+makedepends=(python-setuptools)
conflicts=(python2-requests-cache)
source=("https://files.pythonhosted.org/packages/source/r/$_pkgname/$_pkgname-$pkgver.tar.gz")
sha256sums=('d17c95b0fa52670044356378886dbaf8e25069123d4fced43e05cd13b38c42f8')
@@ -20,11 +20,13 @@ sha256sums=('d17c95b0fa52670044356378886dbaf8e25069123d4fced43e05cd13b38c42f8')
build() {
cd "$srcdir/$_pkgname-$pkgver"
python setup.py build
+ # poetry build --format wheel
}
package() {
cd "$srcdir/$_pkgname-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ # PIP_CONFIG_FILE=/dev/null pip install --isolated --root="${pkgdir}" --ignore-installed --no-deps dist/*.whl
install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm 644 README.md "$pkgdir/usr/share/doc/$pkgname/README"