summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-07-01 11:10:13 -0500
committerCarlos Aznarán Laos2023-07-01 11:10:13 -0500
commit849b0e4a8d712d5803e40e003ce50b07768915a6 (patch)
tree24977b4addfee4dbbbbc899ccaf20a667b84bcc1
parent472381c2b695b228b09ae69ae8f6edf46b42d05e (diff)
downloadaur-849b0e4a8d712d5803e40e003ce50b07768915a6.tar.gz
Bump version to 1.1.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD12
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85979b3c9cfa..012b7fd80b64 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = python-requests-cache
pkgdesc = A persistent cache for python requests
- pkgver = 1.0.1
- pkgrel = 2
+ pkgver = 1.1.0
+ pkgrel = 1
url = https://github.com/requests-cache/requests-cache
arch = any
license = custom:BSD-2-clause
checkdepends = python-pytest
checkdepends = python-requests-mock
checkdepends = python-responses
- checkdepends = python-itsdangerous
- checkdepends = python-ujson
checkdepends = python-timeout-decorator
+ checkdepends = python-time-machine
checkdepends = python-rich
- makedepends = python-poetry-core
+ checkdepends = python-ujson
+ checkdepends = python-itsdangerous
makedepends = python-build
makedepends = python-installer
+ makedepends = python-poetry-core
makedepends = python-wheel
depends = python-requests
depends = python-cattrs
@@ -28,7 +29,7 @@ pkgbase = python-requests-cache
optdepends = python-itsdangerous: for pass trusted data to untrusted environments
optdepends = python-yaml: for bindings yaml support
optdepends = python-ujson: for JSON serializer for improved performance
- source = requests-cache-1.0.1.tar.gz::https://github.com/requests-cache/requests-cache/archive/v1.0.1.tar.gz
- sha512sums = ec5788e31f60fd95e575d01af1163f981757972db6557d7a62da2ca0719e84262cf66cdd9b40c73cca540b92d6b7f6beba1aa42bedba528734c61edf5013ec3d
+ source = requests-cache-1.1.0.tar.gz::https://github.com/requests-cache/requests-cache/archive/v1.1.0.tar.gz
+ sha512sums = 8fa9fdf4f47d67a6ad877fc181e04378b4540b35cef200735caff14e4907519aa5de74acaf61c6588856d5c8b2f9529768250a8e5fe28962b7861daf2279bb94
pkgname = python-requests-cache
diff --git a/PKGBUILD b/PKGBUILD
index a284379ec020..89bd8bb684e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,13 @@
_base=requests-cache
pkgname=python-${_base}
pkgdesc="A persistent cache for python requests"
-pkgver=1.0.1
-pkgrel=2
+pkgver=1.1.0
+pkgrel=1
arch=(any)
url="https://github.com/${_base}/${_base}"
license=('custom:BSD-2-clause')
depends=(python-requests python-cattrs python-platformdirs python-url-normalize)
-makedepends=(python-poetry-core python-build python-installer python-wheel)
+makedepends=(python-build python-installer python-poetry-core python-wheel)
optdepends=('python-boto3: Cache backend for Amazon DynamoDB database'
'python-botocore: Interface for Amazon Web Services'
'python-pymongo: Cache backend for MongoDB database'
@@ -24,9 +24,10 @@ optdepends=('python-boto3: Cache backend for Amazon DynamoDB database'
'python-yaml: for bindings yaml support'
'python-ujson: for JSON serializer for improved performance'
)
-checkdepends=(python-pytest python-requests-mock python-responses python-itsdangerous python-ujson python-timeout-decorator python-rich)
+checkdepends=(python-pytest python-requests-mock python-responses python-timeout-decorator
+ python-time-machine python-rich python-ujson python-itsdangerous)
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('ec5788e31f60fd95e575d01af1163f981757972db6557d7a62da2ca0719e84262cf66cdd9b40c73cca540b92d6b7f6beba1aa42bedba528734c61edf5013ec3d')
+sha512sums=('8fa9fdf4f47d67a6ad877fc181e04378b4540b35cef200735caff14e4907519aa5de74acaf61c6588856d5c8b2f9529768250a8e5fe28962b7861daf2279bb94')
build() {
cd ${_base}-${pkgver}
@@ -38,7 +39,6 @@ build() {
check() {
cd ${_base}-${pkgver}
- # https://bugs.archlinux.org/task/75188
python -m pytest --ignore=tests/integration
}