summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShibumi2015-09-21 15:57:33 +0200
committerShibumi2015-09-21 15:57:33 +0200
commitff942f862edc11d6013d2306700af8e9513aa3ca (patch)
treec9be07be11a4485a057ab91e326bea50bc1b8906
downloadaur-ff942f862edc11d6013d2306700af8e9513aa3ca.tar.gz
initial push
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..274c149c99da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-requests-cache
+ pkgdesc = Persistent cache for requests library
+ pkgver = 0.4.10
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/requests-cache#downloads
+ arch = any
+ license = BSD
+ makedepends = python
+ makedepends = python2
+ source = https://pypi.python.org/packages/source/r/requests-cache/requests-cache-0.4.10.zip
+ sha512sums = 1ddb9becb15d5ad580b90d297bd078fa0c154a382777b1a0d72bbd4fd5b1e47d56bd41d5220c1d0e66521b69800c9730af6d9b7261f97a907bd05f628754fe05
+
+pkgname = python-requests-cache
+ depends = python
+
+pkgname = python2-requests-cache
+ depends = python2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48c031684614
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Christian Rebischke <echo Q2hyaXMuUmViaXNjaGtlQGdtYWlsLmNvbQo= | base64 -d>
+
+pkgbase=python-requests-cache
+_pyname=requests-cache
+pkgname=('python-requests-cache' 'python2-requests-cache')
+makedepends=('python' 'python2')
+pkgver=0.4.10
+pkgrel=1
+pkgdesc="Persistent cache for requests library"
+arch=('any')
+url="https://pypi.python.org/pypi/requests-cache#downloads"
+license=('BSD')
+source=("https://pypi.python.org/packages/source/r/$_pyname/$_pyname-$pkgver.zip")
+sha512sums=('1ddb9becb15d5ad580b90d297bd078fa0c154a382777b1a0d72bbd4fd5b1e47d56bd41d5220c1d0e66521b69800c9730af6d9b7261f97a907bd05f628754fe05')
+
+package_python-requests-cache() {
+ depends=('python')
+ cd "$srcdir/$_pyname-$pkgver"
+ python setup.py install -O1 --root=$pkgdir
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README"
+
+}
+
+package_python2-requests-cache() {
+ depends=('python2')
+ cd "$srcdir/$_pyname-$pkgver"
+ python2 setup.py install -O1 --root=$pkgdir
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README"
+
+}
+
+# vim:set ts=2 sw=2 et:
+