summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2021-07-14 14:37:47 -0500
committerCarlos Aznarán Laos2021-07-14 14:37:47 -0500
commit157799f8bb011189f7de10ee5b4ca9bb02a24b0d (patch)
treed295d1ef0989b6246a59a1716e28456551d3a83c
parent7a0a1c736434bc0af355c8a8b9d6b094f5f44897 (diff)
downloadaur-157799f8bb011189f7de10ee5b4ca9bb02a24b0d.tar.gz
Bump to last version
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD60
3 files changed, 59 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08afcef89bab..1af9b8e14330 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,24 @@
pkgbase = python-requests-cache-git
- pkgdesc = Persistent cache for requests library(git version)
- pkgver = 0.1
+ pkgdesc = Transparent persistent cache for http://python-requests.org library (git version)
+ pkgver = r619.5e2abd0
pkgrel = 1
url = https://github.com/reclosedev/requests-cache
arch = any
- license = BSD
+ license = custom:BSD-2-clause
makedepends = git
makedepends = python-setuptools
- depends = python
- source = python-requests-cache-git::git+https://github.com/reclosedev/requests-cache
- md5sums = SKIP
+ makedepends = python-dephell
+ depends = python-attrs
+ depends = python-itsdangerous
+ depends = python-requests
+ depends = python-url-normalize
+ depends = python-cattrs
+ depends = python-boto3
+ depends = python-redis
+ depends = python-pymongo
+ provides = python-requests-cache
+ conflicts = python-requests-cache
+ source = python-requests-cache::git+https://github.com/reclosedev/requests-cache
+ sha512sums = SKIP
pkgname = python-requests-cache-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index da5fb932adbc..39e70d59cbab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,52 @@
-# Maintainer: LinArcX <LinArcX at gmail . com>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: LinArcX <LinArcX at gmail . com>
-pkgname=python-requests-cache-git
-pkgver=0.1
+_base=requests-cache
+pkgname=python-${_base}-git
+_pkgname=${pkgname%-git}
+pkgdesc="Transparent persistent cache for http://python-requests.org library (git version)"
+pkgver=r619.5e2abd0
pkgrel=1
-pkgdesc="Persistent cache for requests library(git version)"
arch=('any')
-url="https://github.com/reclosedev/requests-cache"
-license=('BSD')
-depends=('python')
-makedepends=('git' 'python-setuptools')
-source=("${pkgname}::git+https://github.com/reclosedev/requests-cache")
-md5sums=('SKIP')
+url="https://github.com/reclosedev/${_base}"
+license=('custom:BSD-2-clause')
+depends=('python-attrs' 'python-itsdangerous' 'python-requests' 'python-url-normalize' 'python-cattrs' 'python-boto3' 'python-redis' 'python-pymongo')
+makedepends=('git' 'python-setuptools' 'python-dephell')
+# checkdepends=(python-pytest python-requests-mock python-timeout-decorator redis python-ujson)
+source=("${_pkgname}::git+${url}")
+sha512sums=('SKIP')
+provides=(${_pkgname})
+conflicts=(${_pkgname})
+
+export PYTHONPYCACHEPREFIX="${BUILDDIR}/${pkgname}/.cache/cpython/" || return 1
pkgver() {
- cd "$srcdir/${pkgname}"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${_pkgname}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
)
}
+prepare() {
+ cd "${_pkgname}"
+ dephell deps convert --from pyproject.toml --to setup.py
+}
+
+build() {
+ cd "${_pkgname}"
+ python setup.py build
+}
+
+# check() {
+# cd "${_pkgname}"
+# python setup.py install --root="${PWD}/tmp_install" --optimize=1
+# PYTHONPATH="${PWD}/tmp_install$(python -c "import site; print(site.getsitepackages()[0])"):${PYTHONPATH}" python -m pytest
+# }
+
package() {
- cd "${srcdir}/${pkgname}"
- python setup.py install --prefix=/usr --root="$pkgdir"
- install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm 644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README"
+ cd "${_pkgname}"
+ export PYTHONHASHSEED=0
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${_pkgname}"
} \ No newline at end of file