summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2021-10-28 18:29:26 -0500
committerCarlos Aznarán Laos2021-10-28 18:29:26 -0500
commit260b8786d5e804d935771e2a0df376dc63666b84 (patch)
treef12ceed843c3df262d9571cab2ab8943279deb48
parent2eab08804a43cbe3e2aab7ce85f34728b7d450c1 (diff)
downloadaur-260b8786d5e804d935771e2a0df376dc63666b84.tar.gz
Remove PYTHONPYCACHEPREFIX
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9d57d62c1eb..876b8d6e0627 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-requests-cache-git
pkgdesc = Transparent persistent cache for http://python-requests.org library (git version)
- pkgver = 0.8.1.r20.g217397b
+ pkgver = 0.8.1.r43.g0199f06
pkgrel = 1
url = https://github.com/reclosedev/requests-cache
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 47667d1633ab..bcfb02210cc2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,12 @@
+# Maintainer: Jordan Cook <JCook83@gmail.com>
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Benoit Pierre <benoit.pierre@gmail.com>
# Contributor: LinArcX <LinArcX at gmail . com>
_base=requests-cache
pkgname=python-${_base}-git
_pkgname=${pkgname%-git}
pkgdesc="Transparent persistent cache for http://python-requests.org library (git version)"
-pkgver=0.8.1.r20.g217397b
+pkgver=0.8.1.r43.g0199f06
pkgrel=1
arch=('any')
url="https://github.com/reclosedev/${_base}"
@@ -28,7 +30,10 @@ pkgver() {
build() {
cd "${_base}"
- python -m build --wheel --skip-dependency-check --no-isolation
+ # Note: set `GIT_CEILING_DIRECTORIES` to prevent poetry
+ # from incorrectly using a parent git checkout info.
+ # https://github.com/pypa/build/issues/384#issuecomment-947675975
+ GIT_CEILING_DIRECTORIES="${PWD}/.." python -m build --wheel --skip-dependency-check --no-isolation
}
check() {
@@ -39,6 +44,6 @@ check() {
package() {
cd "${_base}"
export PYTHONHASHSEED=0
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m install --optimize=1 --destdir="${pkgdir}" dist/*.whl
+ python -m install --optimize=1 --destdir="${pkgdir}" dist/*.whl
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${_pkgname}"
}