summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2021-10-01 13:55:05 -0500
committerCarlos Aznarán Laos2021-10-01 13:55:05 -0500
commit2eab08804a43cbe3e2aab7ce85f34728b7d450c1 (patch)
treea5af2730e19c94e06e81e008bc0d8a3feca4c93e
parent43ab9e9471cd9f236870383d49f326d960ac4254 (diff)
downloadaur-2eab08804a43cbe3e2aab7ce85f34728b7d450c1.tar.gz
Change pkgver() function
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6dba6ad3d181..d9d57d62c1eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-requests-cache-git
pkgdesc = Transparent persistent cache for http://python-requests.org library (git version)
- pkgver = 0.8.r1.80d1b5c
+ pkgver = 0.8.1.r20.g217397b
pkgrel = 1
url = https://github.com/reclosedev/requests-cache
arch = any
@@ -24,7 +24,7 @@ pkgbase = python-requests-cache-git
optdepends = python-pymongo: Cache backend for MongoDB database
provides = python-requests-cache
conflicts = python-requests-cache
- source = git+https://github.com/reclosedev/requests-cache#commit=80d1b5c5aadbce0f04cf6a2cc765c07c21c6ba16
+ source = git+https://github.com/reclosedev/requests-cache
sha512sums = SKIP
pkgname = python-requests-cache-git
diff --git a/PKGBUILD b/PKGBUILD
index 64560bfd3a59..47667d1633ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,8 @@
_base=requests-cache
pkgname=python-${_base}-git
_pkgname=${pkgname%-git}
-_gitcommit=80d1b5c5aadbce0f04cf6a2cc765c07c21c6ba16
pkgdesc="Transparent persistent cache for http://python-requests.org library (git version)"
-pkgver=0.8.r1.80d1b5c
+pkgver=0.8.1.r20.g217397b
pkgrel=1
arch=('any')
url="https://github.com/reclosedev/${_base}"
@@ -17,14 +16,14 @@ optdepends=('python-boto3: Cache backend for Amazon DynamoDB database'
'python-pymongo: Cache backend for MongoDB database') # python-botocore python-yaml python-sphinx-furo python-linkify-it-py python-myst-parser
checkdepends=(python-pytest python-requests-mock python-responses python-itsdangerous python-ujson python-timeout-decorator)
# python-pymongo python-redis redis python-boto3
-source=("git+${url}#commit=${_gitcommit}")
+source=("git+${url}")
sha512sums=('SKIP')
provides=(${_pkgname})
conflicts=(${_pkgname})
pkgver() {
cd "${_base}"
- printf "0.8.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {