summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2021-12-12 18:05:54 -0500
committerCarlos Aznarán Laos2021-12-12 18:05:54 -0500
commit4123bed7b58ad433887a0d629b0a7aa856b76257 (patch)
tree88e4eff17be33c0501621e6db14db80d6367057b
parent260b8786d5e804d935771e2a0df376dc63666b84 (diff)
downloadaur-4123bed7b58ad433887a0d629b0a7aa856b76257.tar.gz
Add optional dependencies for requests-cache 0.9
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD12
2 files changed, 17 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 876b8d6e0627..f429e697dcab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-requests-cache-git
pkgdesc = Transparent persistent cache for http://python-requests.org library (git version)
- pkgver = 0.8.1.r43.g0199f06
+ pkgver = 0.9.0.r68.g71ea521
pkgrel = 1
url = https://github.com/reclosedev/requests-cache
arch = any
@@ -16,12 +16,17 @@ pkgbase = python-requests-cache-git
makedepends = python-poetry
makedepends = git
depends = python-requests
- depends = python-url-normalize
- depends = python-cattrs
depends = python-appdirs
+ depends = python-cattrs
+ depends = python-url-normalize
optdepends = python-boto3: Cache backend for Amazon DynamoDB database
- optdepends = python-redis: Cache backend for Redis cache
+ optdepends = python-botocore: Interface for Amazon Web Services
optdepends = python-pymongo: Cache backend for MongoDB database
+ optdepends = python-redis: Cache backend for Redis cache
+ optdepends = python-bson: for BSON codec
+ optdepends = python-itsdangerous: for pass trusted data to untrusted environments
+ optdepends = python-yaml: for bindings yaml support
+ optdepends = python-ujson: for JSON serializer for improved performance
provides = python-requests-cache
conflicts = python-requests-cache
source = git+https://github.com/reclosedev/requests-cache
diff --git a/PKGBUILD b/PKGBUILD
index bcfb02210cc2..fabe484eaf51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,18 +6,22 @@ _base=requests-cache
pkgname=python-${_base}-git
_pkgname=${pkgname%-git}
pkgdesc="Transparent persistent cache for http://python-requests.org library (git version)"
-pkgver=0.8.1.r43.g0199f06
+pkgver=0.9.0.r68.g71ea521
pkgrel=1
arch=('any')
url="https://github.com/reclosedev/${_base}"
license=('custom:BSD-2-clause')
-depends=(python-requests python-url-normalize python-cattrs python-appdirs)
+depends=(python-requests python-appdirs python-cattrs python-url-normalize)
makedepends=(python-build python-install python-poetry git)
optdepends=('python-boto3: Cache backend for Amazon DynamoDB database'
+ 'python-botocore: Interface for Amazon Web Services'
+ 'python-pymongo: Cache backend for MongoDB database'
'python-redis: Cache backend for Redis cache'
- 'python-pymongo: Cache backend for MongoDB database') # python-botocore python-yaml python-sphinx-furo python-linkify-it-py python-myst-parser
+ 'python-bson: for BSON codec'
+ 'python-itsdangerous: for pass trusted data to untrusted environments'
+ 'python-yaml: for bindings yaml support'
+ 'python-ujson: for JSON serializer for improved performance') # python-sphinx-furo python-linkify-it-py python-myst-parser
checkdepends=(python-pytest python-requests-mock python-responses python-itsdangerous python-ujson python-timeout-decorator)
-# python-pymongo python-redis redis python-boto3
source=("git+${url}")
sha512sums=('SKIP')
provides=(${_pkgname})