summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2021-09-30 16:32:41 -0500
committerCarlos Aznarán Laos2021-09-30 16:32:41 -0500
commit43ab9e9471cd9f236870383d49f326d960ac4254 (patch)
tree3e50c6414049cfabe8ecac78386c38b3d1f7942f
parentc64e9b5e0daa141441822e033cf83612a9ca9b5b (diff)
downloadaur-43ab9e9471cd9f236870383d49f326d960ac4254.tar.gz
Change PYTHONPYCACHEPREFIX path
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index edf0b27c6345..6dba6ad3d181 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-requests-cache-git
pkgdesc = Transparent persistent cache for http://python-requests.org library (git version)
- pkgver = 0.8.r1.4f13fb2
+ pkgver = 0.8.r1.80d1b5c
pkgrel = 1
url = https://github.com/reclosedev/requests-cache
arch = any
@@ -24,7 +24,7 @@ pkgbase = python-requests-cache-git
optdepends = python-pymongo: Cache backend for MongoDB database
provides = python-requests-cache
conflicts = python-requests-cache
- source = git+https://github.com/reclosedev/requests-cache#commit=4f13fb21bec27d1a89f585bfa544411844594cb6
+ source = git+https://github.com/reclosedev/requests-cache#commit=80d1b5c5aadbce0f04cf6a2cc765c07c21c6ba16
sha512sums = SKIP
pkgname = python-requests-cache-git
diff --git a/PKGBUILD b/PKGBUILD
index aef7d4a266d0..64560bfd3a59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
_base=requests-cache
pkgname=python-${_base}-git
_pkgname=${pkgname%-git}
-_gitcommit=4f13fb21bec27d1a89f585bfa544411844594cb6
+_gitcommit=80d1b5c5aadbce0f04cf6a2cc765c07c21c6ba16
pkgdesc="Transparent persistent cache for http://python-requests.org library (git version)"
-pkgver=0.8.r1.4f13fb2
+pkgver=0.8.r1.80d1b5c
pkgrel=1
arch=('any')
url="https://github.com/reclosedev/${_base}"
@@ -22,8 +22,6 @@ sha512sums=('SKIP')
provides=(${_pkgname})
conflicts=(${_pkgname})
-export PYTHONPYCACHEPREFIX="${BUILDDIR}/${pkgname}/.cache/cpython/"
-
pkgver() {
cd "${_base}"
printf "0.8.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
@@ -42,6 +40,6 @@ check() {
package() {
cd "${_base}"
export PYTHONHASHSEED=0
- python -m install --optimize=1 --destdir="${pkgdir}" dist/*.whl
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m install --optimize=1 --destdir="${pkgdir}" dist/*.whl
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${_pkgname}"
}