summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-10-25 14:38:06 -0500
committerCarlos Aznarán Laos2022-10-25 14:38:06 -0500
commit58155a9fcdf784ad25c0ba317070dd3775eb5c2a (patch)
treec6b87a10bc3c04a2e19c800e58cb072fef002505
parent91ee1430f961aa1aaa6ffb3428dcfbc03d8147f9 (diff)
downloadaur-58155a9fcdf784ad25c0ba317070dd3775eb5c2a.tar.gz
Change python-install by python-installer
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ff54363a11f..72f353952071 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-requests-cache-git
pkgdesc = Transparent persistent cache for http://python-requests.org library (git version)
- pkgver = 0.9.3.r202.g8cd28d1
+ pkgver = 0.9.3.r234.gd502885
pkgrel = 1
url = https://github.com/reclosedev/requests-cache
arch = any
@@ -13,7 +13,7 @@ pkgbase = python-requests-cache-git
checkdepends = python-timeout-decorator
checkdepends = python-rich
makedepends = python-build
- makedepends = python-install
+ makedepends = python-installer
makedepends = python-poetry
makedepends = git
depends = python-requests
diff --git a/PKGBUILD b/PKGBUILD
index cdb918439ab0..7e5359965354 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,13 +6,13 @@ _base=requests-cache
pkgname=python-${_base}-git
_pkgname=${pkgname%-git}
pkgdesc="Transparent persistent cache for http://python-requests.org library (git version)"
-pkgver=0.9.3.r202.g8cd28d1
+pkgver=0.9.3.r234.gd502885
pkgrel=1
arch=(any)
url="https://github.com/reclosedev/${_base}"
license=('custom:BSD-2-clause')
depends=(python-requests python-platformdirs python-cattrs python-url-normalize)
-makedepends=(python-build python-install python-poetry git)
+makedepends=(python-build python-installer python-poetry git)
optdepends=('python-boto3: Cache backend for Amazon DynamoDB database'
'python-botocore: Interface for Amazon Web Services'
'python-pymongo: Cache backend for MongoDB database'
@@ -47,6 +47,6 @@ check() {
package() {
cd ${_base}
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m install --optimize=1 --destdir="${pkgdir}" dist/*.whl
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${_pkgname}"
}