summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-08-22 23:27:13 -0500
committerCarlos Aznarán Laos2022-08-22 23:27:13 -0500
commit91ee1430f961aa1aaa6ffb3428dcfbc03d8147f9 (patch)
treecfef9e6ba540fa44a42b7883bc8806bce81061cc
parent76d9d554a3548cabb05f358e3cb0c72478649587 (diff)
downloadaur-91ee1430f961aa1aaa6ffb3428dcfbc03d8147f9.tar.gz
Add check() function
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 636aad61f915..3ff54363a11f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,17 @@
pkgbase = python-requests-cache-git
pkgdesc = Transparent persistent cache for http://python-requests.org library (git version)
- pkgver = 0.9.3.r194.g072ff2d
+ pkgver = 0.9.3.r202.g8cd28d1
pkgrel = 1
url = https://github.com/reclosedev/requests-cache
arch = any
license = custom:BSD-2-clause
+ checkdepends = python-pytest
+ checkdepends = python-requests-mock
+ checkdepends = python-responses
+ checkdepends = python-itsdangerous
+ checkdepends = python-ujson
+ checkdepends = python-timeout-decorator
+ checkdepends = python-rich
makedepends = python-build
makedepends = python-install
makedepends = python-poetry
@@ -13,7 +20,6 @@ pkgbase = python-requests-cache-git
depends = python-platformdirs
depends = python-cattrs
depends = python-url-normalize
- depends = python-exceptiongroup
optdepends = python-boto3: Cache backend for Amazon DynamoDB database
optdepends = python-botocore: Interface for Amazon Web Services
optdepends = python-pymongo: Cache backend for MongoDB database
diff --git a/PKGBUILD b/PKGBUILD
index 662df2bb93d6..cdb918439ab0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,12 @@ _base=requests-cache
pkgname=python-${_base}-git
_pkgname=${pkgname%-git}
pkgdesc="Transparent persistent cache for http://python-requests.org library (git version)"
-pkgver=0.9.3.r194.g072ff2d
+pkgver=0.9.3.r202.g8cd28d1
pkgrel=1
arch=(any)
url="https://github.com/reclosedev/${_base}"
license=('custom:BSD-2-clause')
-depends=(python-requests python-platformdirs python-cattrs python-url-normalize python-exceptiongroup)
+depends=(python-requests python-platformdirs python-cattrs python-url-normalize)
makedepends=(python-build python-install python-poetry git)
optdepends=('python-boto3: Cache backend for Amazon DynamoDB database'
'python-botocore: Interface for Amazon Web Services'
@@ -21,7 +21,7 @@ optdepends=('python-boto3: Cache backend for Amazon DynamoDB database'
'python-itsdangerous: for pass trusted data to untrusted environments'
'python-yaml: for bindings yaml support'
'python-ujson: for JSON serializer for improved performance') # python-sphinx-furo python-linkify-it-py python-myst-parser
-# checkdepends=(python-pytest python-requests-mock python-responses python-itsdangerous python-ujson python-timeout-decorator python-rich)
+checkdepends=(python-pytest python-requests-mock python-responses python-itsdangerous python-ujson python-timeout-decorator python-rich)
source=("git+${url}")
sha512sums=('SKIP')
provides=(${_pkgname})
@@ -37,14 +37,13 @@ build() {
# Note: set `GIT_CEILING_DIRECTORIES` to prevent poetry
# from incorrectly using a parent git checkout info.
# https://github.com/pypa/build/issues/384#issuecomment-947675975
- export PYTHONHASHSEED=0
GIT_CEILING_DIRECTORIES="${PWD}/.." python -m build --wheel --skip-dependency-check --no-isolation
}
-# check() {
-# cd ${_base}
-# python -m pytest --ignore=tests/integration
-# }
+check() {
+ cd ${_base}
+ python -m pytest --ignore=tests/integration
+}
package() {
cd ${_base}