summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-04-10 17:40:00 -0500
committerCarlos Aznarán Laos2022-04-10 17:40:00 -0500
commitf01a32938c6b8ce5f40dc9cf5cc11794aab4118e (patch)
tree3f0724528f32d0267718e1943e8e864ceea6b6d6
parentb6e72e4a2bd82767a2dda4d041126679081c739a (diff)
downloadaur-f01a32938c6b8ce5f40dc9cf5cc11794aab4118e.tar.gz
Add python-rich as checkdependency
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14e21cdaad0b..ab3b0a306cb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-requests-cache-git
pkgdesc = Transparent persistent cache for http://python-requests.org library (git version)
- pkgver = 0.9.0.r68.g71ea521
- pkgrel = 2
+ pkgver = 0.9.3.r59.g8fa9c24
+ pkgrel = 1
url = https://github.com/reclosedev/requests-cache
arch = any
license = custom:BSD-2-clause
@@ -11,6 +11,7 @@ pkgbase = python-requests-cache-git
checkdepends = python-itsdangerous
checkdepends = python-ujson
checkdepends = python-timeout-decorator
+ checkdepends = python-rich
makedepends = python-build
makedepends = python-install
makedepends = python-poetry
diff --git a/PKGBUILD b/PKGBUILD
index 3b44c6ffa782..168c5151e52c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,9 +6,9 @@ _base=requests-cache
pkgname=python-${_base}-git
_pkgname=${pkgname%-git}
pkgdesc="Transparent persistent cache for http://python-requests.org library (git version)"
-pkgver=0.9.0.r68.g71ea521
-pkgrel=2
-arch=('any')
+pkgver=0.9.3.r59.g8fa9c24
+pkgrel=1
+arch=(any)
url="https://github.com/reclosedev/${_base}"
license=('custom:BSD-2-clause')
depends=(python-requests python-appdirs python-cattrs python-url-normalize)
@@ -21,7 +21,7 @@ optdepends=('python-boto3: Cache backend for Amazon DynamoDB database'
'python-itsdangerous: for pass trusted data to untrusted environments'
'python-yaml: for bindings yaml support'
'python-ujson: for JSON serializer for improved performance') # python-sphinx-furo python-linkify-it-py python-myst-parser
-checkdepends=(python-pytest python-requests-mock python-responses python-itsdangerous python-ujson python-timeout-decorator)
+checkdepends=(python-pytest python-requests-mock python-responses python-itsdangerous python-ujson python-timeout-decorator python-rich)
source=("git+${url}")
sha512sums=('SKIP')
provides=(${_pkgname})
@@ -37,6 +37,7 @@ build() {
# Note: set `GIT_CEILING_DIRECTORIES` to prevent poetry
# from incorrectly using a parent git checkout info.
# https://github.com/pypa/build/issues/384#issuecomment-947675975
+ export PYTHONHASHSEED=0
GIT_CEILING_DIRECTORIES="${PWD}/.." python -m build --wheel --skip-dependency-check --no-isolation
}
@@ -48,6 +49,6 @@ check() {
package() {
cd "${_base}"
export PYTHONHASHSEED=0
- python -m install --optimize=1 --destdir="${pkgdir}" dist/*.whl
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m install --optimize=1 --destdir="${pkgdir}" dist/*.whl
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${_pkgname}"
}