summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlberto Redondo2021-01-23 17:14:13 +0100
committerAlberto Redondo2021-01-23 17:14:13 +0100
commitecb9fb3b192f98675f25579304c53b4ba1ba922f (patch)
tree9e57cea87f06ab2aa68d2860762101ba5016e8b3
parent931426b8f90b9e69de9dbf347ae9e8234507b6d7 (diff)
downloadaur-python-requests-futures.tar.gz
Adopted orphan package; code style revision; license now in lowercase
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD34
2 files changed, 24 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7af8488183cb..348874ce25b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = python-requests-futures
pkgdesc = Asynchronous Python HTTP Requests for Humans
pkgver = 1.0.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/ross/requests-futures
arch = any
- license = APACHE
+ license = Apache
makedepends = python-setuptools
depends = python-requests
source = https://files.pythonhosted.org/packages/source/r/requests-futures/requests-futures-1.0.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index eed6f013036b..d014d852a6cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,40 @@
-# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Maintainer: Alberto Redondo <albertomost at gmail dot com>
+# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
# Contributor: Chih-Hsuan Yen <yan12125@gmail.com>
# Contributor: Alexander 'z33ky' Hirsch <1zeeky@gmail.com>
-_pkgname='requests-futures'
-pkgname="python-${_pkgname}"
+_pkgname=requests-futures
+pkgname=python-${_pkgname}
pkgver=1.0.0
-pkgrel=2
+pkgrel=3
pkgdesc='Asynchronous Python HTTP Requests for Humans'
arch=('any')
url='https://github.com/ross/requests-futures'
_url_pypi='https://pypi.org/project/requests-futures'
-license=('APACHE')
+license=('Apache')
depends=('python-requests')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+source=(https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz)
sha256sums=('35547502bf1958044716a03a2f47092a89efe8f9789ab0c4c528d9c9c30bc148')
build() {
- cd "${_pkgname}-${pkgver}"
+
+ cd ${_pkgname}-${pkgver}
+
python setup.py build
+
}
package() {
- cd "${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dvm644 'README.rst' -t "${pkgdir}/usr/share/doc/${pkgname}"
-}
-# vim: ts=2 sw=2 et:
+ cd ${_pkgname}-${pkgver}
+
+ python setup.py install \
+ -O1 \
+ --root="${pkgdir}" \
+ --skip-build
+
+ install -Dvm644 'README.rst' \
+ -t "${pkgdir}/usr/share/doc/${pkgname}"
+
+}