summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-12-03 09:26:23 +1300
committercaltlgin2020-12-03 09:26:23 +1300
commit931426b8f90b9e69de9dbf347ae9e8234507b6d7 (patch)
treeb315819df6ee2a1c52350ed77088c86b5cca1a8a
parenteab1349a6f410ec5667683dfb0890dceced76cb6 (diff)
downloadaur-931426b8f90b9e69de9dbf347ae9e8234507b6d7.tar.gz
Python 3.9 rebuild
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD10
3 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 651328fe2693..7af8488183cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
pkgbase = python-requests-futures
pkgdesc = Asynchronous Python HTTP Requests for Humans
pkgver = 1.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ross/requests-futures
arch = any
license = APACHE
makedepends = python-setuptools
- depends = python
depends = python-requests
- provides = python-requests-futures
source = https://files.pythonhosted.org/packages/source/r/requests-futures/requests-futures-1.0.0.tar.gz
sha256sums = 35547502bf1958044716a03a2f47092a89efe8f9789ab0c4c528d9c9c30bc148
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 02dd9f2c8c02..eed6f013036b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
# Contributor: Chih-Hsuan Yen <yan12125@gmail.com>
# Contributor: Alexander 'z33ky' Hirsch <1zeeky@gmail.com>
-_pkgname=requests-futures
+_pkgname='requests-futures'
pkgname="python-${_pkgname}"
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='Asynchronous Python HTTP Requests for Humans'
arch=('any')
url='https://github.com/ross/requests-futures'
+_url_pypi='https://pypi.org/project/requests-futures'
license=('APACHE')
-depends=('python' 'python-requests')
+depends=('python-requests')
makedepends=('python-setuptools')
-provides=("${pkgname}")
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
sha256sums=('35547502bf1958044716a03a2f47092a89efe8f9789ab0c4c528d9c9c30bc148')
@@ -24,7 +24,7 @@ build() {
package() {
cd "${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" 'README.rst'
+ install -Dvm644 'README.rst' -t "${pkgdir}/usr/share/doc/${pkgname}"
}
# vim: ts=2 sw=2 et: