summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-08-14 09:17:28 +1200
committercaltlgin2020-08-14 09:17:28 +1200
commiteab1349a6f410ec5667683dfb0890dceced76cb6 (patch)
tree718a8b3969ec310e83c63fb038f23ac11fcf0a99
parente34a7f7fb50801d4adaa8324bf1e354bfc05dc32 (diff)
downloadaur-eab1349a6f410ec5667683dfb0890dceced76cb6.tar.gz
Adopt PKGBUILD. Add README
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD31
2 files changed, 20 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 712fefeb9a62..651328fe2693 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = python-requests-futures
- pkgdesc = Asynchronous Python HTTP for Humans.
+ pkgdesc = Asynchronous Python HTTP Requests for Humans
pkgver = 1.0.0
pkgrel = 1
url = https://github.com/ross/requests-futures
arch = any
- license = Apache
+ license = APACHE
makedepends = python-setuptools
+ depends = python
depends = python-requests
+ provides = python-requests-futures
source = https://files.pythonhosted.org/packages/source/r/requests-futures/requests-futures-1.0.0.tar.gz
sha256sums = 35547502bf1958044716a03a2f47092a89efe8f9789ab0c4c528d9c9c30bc148
diff --git a/PKGBUILD b/PKGBUILD
index 228252ecdfcc..02dd9f2c8c02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
-# Maintainer: Chih-Hsuan Yen <yan12125@gmail.com>
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Contributor: Chih-Hsuan Yen <yan12125@gmail.com>
# Contributor: Alexander 'z33ky' Hirsch <1zeeky@gmail.com>
-pkgname=python-requests-futures
+_pkgname=requests-futures
+pkgname="python-${_pkgname}"
pkgver=1.0.0
pkgrel=1
-pkgdesc='Asynchronous Python HTTP for Humans.'
-license=('Apache')
+pkgdesc='Asynchronous Python HTTP Requests for Humans'
arch=('any')
url='https://github.com/ross/requests-futures'
-depends=('python-requests')
+license=('APACHE')
+depends=('python' 'python-requests')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/r/requests-futures/requests-futures-${pkgver}.tar.gz")
+provides=("${pkgname}")
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
sha256sums=('35547502bf1958044716a03a2f47092a89efe8f9789ab0c4c528d9c9c30bc148')
build() {
- cd requests-futures-$pkgver
- python setup.py build
-}
-
-check() {
- cd requests-futures-$pkgver
- python test_requests_futures.py
+ cd "${_pkgname}-${pkgver}"
+ python setup.py build
}
package() {
- cd requests-futures-$pkgver
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" 'README.rst'
}
+
+# vim: ts=2 sw=2 et: