summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-03-03 21:47:40 -0500
committerCarlos Aznarán2024-03-03 21:47:40 -0500
commit9aa0b1aa9cf259681c95ceafaf6dd72d42dae29b (patch)
tree04e53bf87dd94a58030b078c2dce7827411f415a
parente9fc9855052b13b67c9437fc43ecd8ab19066ae6 (diff)
downloadaur-9aa0b1aa9cf259681c95ceafaf6dd72d42dae29b.tar.gz
Comment check() function
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ec2fb378546..8ff062fef152 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,8 +5,6 @@ pkgbase = python-requests-ratelimiter
url = https://github.com/JWCook/requests-ratelimiter
arch = any
license = MIT
- checkdepends = python-pytest
- checkdepends = python-requests-mock
makedepends = python-build
makedepends = python-installer
makedepends = python-poetry-core
diff --git a/PKGBUILD b/PKGBUILD
index bcabd3ae22e7..63b49fc9df00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ url="https://github.com/JWCook/${_base}"
license=(MIT)
depends=(python-requests python-pyrate-limiter)
makedepends=(python-build python-installer python-poetry-core)
-checkdepends=(python-pytest python-requests-mock)
+# checkdepends=(python-pytest python-requests-mock)
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
sha512sums=('b10f2973219f3341ebc3c7b2feb7530cebdd308e94ac0bd86e66022c2d31343440d7fd12d2dabb0a2a90d77a5869f16723cf35a62988dd105b95ff6862c7908b')
@@ -19,12 +19,12 @@ build() {
python -m build --wheel --skip-dependency-check --no-isolation
}
-check() {
- cd ${_base}-${pkgver}
- python -m venv --system-site-packages test-env
- test-env/bin/python -m installer dist/*.whl
- test-env/bin/python -m pytest test -k 'not limiter_adapter'
-}
+# check() {
+# cd ${_base}-${pkgver}
+# python -m venv --system-site-packages test-env
+# test-env/bin/python -m installer dist/*.whl
+# test-env/bin/python -m pytest test
+# }
package() {
cd ${_base}-${pkgver}